new file created upon erasure


New Member
When I erased a video file (I believe it was an mp4), a new file of the same size was immediately created in the same directory, with a different name and file type assigned. Upon each effort to erase the new file, another is created of the same size, apparently assigning names and suffixes at random. Does the target file contain something that causes it to replicate if erasure is attempted? Is this malware? What can I do about it?

The newly created files do not work, either by just clicking on them, or even if renamed as an mp4 file.
It's part of the file name erasure process. It should go away after the erasure completes; does the task log say anything?
No, it does not go away. All 12,280 KB of it still sitting there, under a new name. The new name does not appear until immediately after the erasure process appears to have completed.

I have erased hundreds and hundreds of files using Eraser, and this is the first time it has ever happened.
Does the task log say anything? File being locked or something?

Alternatively, sometimes Explorer caches the folder contents and is not aware that the file has been deleted, in those situations refreshing the folder should get rid of it.
I not sure what task log you are talking about, or exactly what that is, to be honest.

The newly created files (I've been through about 15 iterations of them now) survive everything I've been able to think of, including reboot. As I mentioned in my first post, my fear is that the file may have contained malware of some sort that is programmed to defeat its erasure by copying its contents into a new file with an innocuous, hopefully unnoticeable name whenever someone tries to erase it. Is it possible for a file containing malware to defeat Eraser like this? If so, is there any other way to erase it? I have not tried to simply "Delete" it, since I know that does not remove anything, just making it invisible unless recovered, and thus more difficult to locate it to continue trying to get rid of it.
The Task Log can be found by right-clicking the Erasure Task in the Eraser window, and selecting View Task Log. If there are errors encountered, Eraser will report them there.

If those files are the same file size as your original file erased, then chances are they are just files left behind by the file name obfuscation function of Eraser. I've seen some files left behind myself, but the problem is usually transient and not reproducible reliably. If this is really the case, the task log will usually report it as an error (and the erase process will correspondingly end with "completed with errors."

Malware can certainly defeat programs like that, but I've not heard of these kinds of malware specifically targeting Eraser. Do you have a good (and reputable) anti virus software?
When I use Eraser , I right-click on the file and chose "Erase" from a menu. A small window appears while the erasure is taking place, but there is no menu by which I can access a task log or anything else. When I go to the Start menu and open the Eraser program, there does not appear to be any history I can find in the menu reflecting the erasures I have done, nor any record of tasks "completed with errors".

I use Avira antivirus, which is updated automatically.

HOWEVER, today I tried again to erase the file again (in its renamed version), and after the process, a new file name did not appear.

Your comments give me a little comfort that it may not have been malware.

It could have been transient, as is most of these problems. I've never used Avira before, so I'd have to depend on community feedback. If more reports come in which suggests that Avira may be interfering with the erase then I would see if I can get in touch with their engineering department (better still if Avira users can direct me on whom to speak to!)