new user /eraser failing to delete unused space


New Member
Win xp I have run eraser on demand and from explorer shell >.new task>unused space on c.>run>with all attributes tips/files names/alternate data streams. plus tried with some attributes off, I have run gutmann and also tried pseudorandom but it fails to delete a thing error log says failed. I installed on d drive and tried to delete unused space in c from there, same thing..happens i get a list of system files and program files saying protected;etc then task failed to it trying to erase all data on c drive?...I know I'm probably doing something stupid but what? :roll:
The files that were not "erased" are system files that Eraser could not wipe the cluster tips or cluster slack of. They are Windows Protected Files. "File slack is, the disk space from the end of a file till the end of the last cluster used by that file." If you uncheck Cluster Tip Area then you should not see this report after a wipe.
You can get software that will disable the protection on system files so you are able to clean them. I can't think of any off the top of my head, but if you search, you'll find :)
Disable Windows File Protection (Windows 2000/XP)
Windows 2000 and XP include a feature called Windows File Protection (WFP), part of the System File Checker, which is intended to avoid some of the common DLL consistency issues. This feature may also block valid attempts to change system files and it can therefore be disabled using this tweak.

SystemKey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Value Name: SFCDisable
Data Type: REG_DWORD (DWORD Value)
Value Data: 0 = enabled (default), ffffff9d = disabled

Change the value of "SFCDisable" to equal "ffffff9d" to disable WFS or "0" to enable it. The other valid hexadecimal values are:

1 - disabled, prompt at boot to re-enable
2 - disabled at next boot only, no prompt to re-enable
4 - enabled, with popups disabled
ffffff9d - for completely disabled
Restart Windows for the change to take effect.