No "Eraser" in context menu


New Member
Installed on new win 7 64 bit - works fine but there is no context menu choice for eraser in Windows Explorer - Installed same on an XP 32 bit machine and context menu choice for "eraser" is there...I have been searching on forum for an exact repeat of this problem but have not been able to find one...has anyone else experienced this and have a solution...Thank you for allowing me to join your forum and I assure you I will not become a pest!
You Win 7 installation has failed in some way; the entries are certainly there on my Window 7 installations.

Do you have this Registry Key:


The value for this key on the machine I am using is


I'll check as soon as I get home...If that isn't it I'll try a few other things and will post if and when I figure it out in case someone else has the same problem
You could just try uninstalling, running a Registry cleaner, then reinstalling. That sometimes works, but, sadly, not always.

getting ready to try that now...I have the registry entry that you referred to earlier (other than different digits in the value field)
nope..cleaned it CLEAN but still the same. I have 2 other programs that have installed context menus and work perfectly...just can't imagine what could be wrong. Eraser works perfectly though, just have to go thru the "New Task" routine to get it there...could be worse so will continue with it as it is and keep an eye on forum to see if problem pops up again in future. In closing, I am impressed with the amount of time you devote to helping people on this forum...There weren't many threads that I checked hoping to find a solution before having to post that I didn't see you trying to help with many different problems others had and I appreciate the time you took to try to help me!!
just one more post on this topic...just to see, I installed Eraser on a Win t x64 laptop with exactly the same result - no context menu! amazing
The install fails, and this then blocks subsequent successful installs. All I can suggest is a full uninstall, followed by full manual cleaning of all Eraser-related entries in the Registry, then reinstall.

that worked on the laptop but not on the original one i had problem with - don't worry about it, i feel confident it's not Eraser and I can still use it fine...again thanks
Guess What...Eraser now in context menu on "stubborn" desktop too - really did nothing else except the complete uninstall and reinstall then turned it on today and there it was...will make a donation just as soon as I can find link!
greatescape said:
will make a donation just as soon as I can find link!
It's in Joel's signature block - if it has been restored following the recent server compromise ...

Anyway, glad it's working. Windows sometimes does take its time to get the message.

Thanks for your support.

For those who are still affected by this, please post back with the system specifications (most importantly OS) and we'll see how best to debug. I am leaning towards a case of missing C++ runtimes (but that should not be a problem -- if you installed Eraser using the .exe from our project page the correct runtime should have been deployed)
Got the same issue on Windows 7 x64 Ultimate:

Eraser > context menu
Eraser > no context menu
Eraser > no context menu

Several separate removals/re-installs also tried with and without running as administrator.
I don't think that the Eraser 6 build, in itself, makes a lot of difference. If Joel is correct in his diagnosis, this would suggest that a brute force uninstall, as previously described, enables the Windows installer to deploy (and, if needed, register) the required runtimes.

I'm having the same issue on window 64 ultimate -- eraser won't show up in explorer context menu. Unusual, because this is a fresh disk install, and I've had no problems at all in the past, with this same OS and computer with 2 different eraser installs. I uninstalled eraser and manually searched for eraser entries in the register and deleted those. Or can you guys recommend a registry cleaner? Any other trouble shooting tips to recommend? Thanks, Scott
I had the same problem, couldn't get the extension on the context menu to appear. What I did to solve it was running ShellExView which showed eraser was disabled. I enabled it and it's appearing now. For some reason it seems like the extension was set to disable by default. Anyway hope this helps some people.
I have the same problem on my fresh install of Windows 7. I tried the ShellExView but without success. It says that my entries are enabled, but It do not show on context menus.
Any help?

Correction: After reading other topics I realize the problem is that Eraser installed the 64-bit version and I'm using Altap Salamander as my file manager and it is a 32-bit application. Since I had the same installed versions of Eraser ( and Altap Salamander (2.54) on a 32-bit machine, I can guarantee that 32-bit shell extensions work perfectly with that specific file manager. So, is there any way to enable them on my 64-bit machine?

(sorry for my bad English)
fifacoinschp said:
Thank you very much. Has been resolved.

Exactly what has been solved? And how?
I posted two questions about problems a couple of days ago and still waiting for some help, so I would appreciate if you share your solution with us.