No eraser methods in Eraser


New Member
I have found this previous post on the topic of 'No file erasure methods to choose' and installed the latest August 2010 set from Microsoft. I have added the Certificate pluggin to the Machine Management Console and can see the Certum CA certificate and proved the thumbprint is the same as in the post. Yet I still have no Erasure methods to choose from.

Has anyone any ideas where I can go next?

Thank you for looking up the previous post and trying the solution there. That at least takes us several steps towards a diagnosis.

In the absence of further thoughts from Joel, I would try completely removing Eraser from your system, re-downloading and reinstalling. That would (nearly) eliminate the possibility that there was something wrong with the installation of Eraser itself.

I uninstalled it. Deleted the directory under Application Data and that for Eraser 5.8.8 too. In the registry I deleted the entries for Eraser and those from 5.8.8 too - both under HKCU\Software.

I then re-installed and tried again. Same error. So I have re-traced my steps and I have found that the Certum CA certificate is only present under the Third-Party Root Certificate Authorities and not in the Trusted Root Certificate Authorities list.

Why would that be? Can I just copy it from one to the other?

Thanks for persisting with this, and sharing more useful information.

I'm afraid don't know the answer to your question (Joel may), but I see no harm in trying the obvious solution.

Yes it should go to the trusted root certs folder, I'm not sure why it isn't...