No Shell Integration, No Drag And Drop.


New Member

I am using Eraser on a Windows XP SP3 machine and both shell integration (no context menu entry when right-clicking on items) and drag and drop do not work. I installed and (after uninstalling the previously installed versions and cleaning all registry entries under HKCU\Software\Eraser 6 and all files under %LOCALAPPDATA%\Eraser 6) but it made no difference and the problem remains. I have also updated my Visual C++ installation (as suggested on another post) but it didn't help.

All other functions are operational and Eraser works fine. I have run Dependency Walker on Eraser.Shell.dll and there are errors. I have attached a snapshot of the scan.

Any solution to this problem? It is not a critical problem by all means but it is annoying and inconvenient because it reduces functionality considerably.


  • Dependency Walker snapshot - Eraser Windows XP SP3.jpg
    Dependency Walker snapshot - Eraser Windows XP SP3.jpg
    235.2 KB · Views: 3
Windows 7 Ultimate SP1

On the Compatibility tab of the Properties window for Eraser, the checkbox under "Privilege Level" for "Run this program as an administrator" is checked. I still have this problem.

No, when installing, I did not select "Run as administrator". If that is necessary, do I have to remove Eraser before reinstalling it with that option?
can you try going to the eraser install directory and running regsvr32 /c
I just now tried that.

First of all, the file is Eraser.Shell.dll, not I do not know, however, whether the file-name is case-sensitive.

More important, I got an error popup. See the following image.
I downloaded and installed Eraser I selected "Run as Administrator" on the install executable. During the installation, I got a notice that .NET was not being installed because I already had a later version of .NET. No, I did not note which version of .NET; but I have at least .NET 3.5.1, 4.5, 4.5.1, 4.5.2, and 4.6.1. Also, during installation, I got the following error popup. I still do not see Eraser in the Windows Explorer pull-down context menu.
This is strange, you are administrator and yet you get this error.
Is the PC your personal one or a company PC?
Try running the command prompt as administrator and then in the eraser directory run
regsvr32 /c
the case is not important.

In the meantime I'll try to find an XP machine to test on.
This is a personal PC. I am using Windows 7 Ultimate SP1 (x64), so I do not understand why you need to check a Windows XP PC.

I launched cmd.exe for "Run as Administrator". I got the same error popup as the last time I tried running regsvr32.
I notified the people at about the download problem, and they fixed it. I already have installed the latest version of Eraser without resolving this problem. See my Aug 28 posting in this topic.
Drag and drop function works not more. Any version of Eraser. Windows 10 Pro 64-bit (10.0, Build 14393)
Programm is not started as admin. Box is unchecked. Erasing function does not work.