NTLDR is Missing. Press CTRL ALT DELETE to reboot.




I have read seen a few other posts from people with the same problem I had.

I am running Windows XP service pack 1, on an NTFS formatted disk.

After running Eraser, the program appeared to have crashed (it just kept on running forever, so I had to end task on it).

Next reboot I got the NTLDR missing error message.
I used the XP bootable cd to go into recovery console. I tried running FIX BOOT and all the other partition repair tools but to no avail. I used the utility to write a clean boot sector, no joy.

The ntldr file was present on my C: root. I rename it, and copied a fresh version from the installation cd. Same problems on reboot.

I tried running chkdsk, nothing found.

In the end I had to install a seperate hard disk along side my unbootable XP one is Slave / Master fashion, this way I was able to salvage my important files before reformattting, and rebuilding my unbootable XP drive.

Does anyone know what causes this, or of any workarounds besides rebuilding your computer ???


if you can access the drive try deleting temp files etc I think it may be that you have ran out of disk space

I got same problem. Eraser crashed so before reboot I open a Dos Box and ran:

del /q /A:H-S *.* on my root because 520,000 files of 720 bytes were there... what a mess. I also deleted the temp folder of eraser so I had 8 Gb of free space on my drive after these operations... The ran scandisk and reboot to do so and guess what????
NTLDR is missing press CTRL ALT DEL!!!!!!!!! What's up all temp files are already deleted, and NTLDR is still there...

So I boot with CD, Recovery console,
fixboot C:
fixmbr C:


still cannot reboot.

So what could I do? Thanks in advance
Partial solution found but...

OK I was now able to restore my previous configuration without loosing anything but I am still puzzled. Here is what I did:

1) Installed another HD as master and the "missing NTLDR" one as slave.
2) Boot with XP CD-Rom and start recovery console, logged in 'D:\windows' installation that the recovery console has deted
3) Run 'fixboot C:' command (to enable my new master drive to boot)
4) Copy ntldr and ntdetect.com files on C:\ the new master drive
5) Run 'bootcfg rebuild' command to detect my windows XP installation on the drive D:\windows and create the file boot.ini on C:\
6) run 'chkdsk /p' command on drive C: and D: (no error found)
7) Go into the BIOS and choose to boot on the new master drive
8) Reboot the system

1) Windows XP started normally and the new master drive is now recognized as D: while the missing NTLDR one is now C:. In other words my OS is still on drive C: as before the corruption even if it is the slave drive. Apparently XP managed to swap the drives letter to always keep the OS on the C: drive.
2) The master drive is now bootable and got boot.ini, ntldr and ntdetect.com
3) My "missing NTLDR" C: drive is healthy, have enough space and no more temp files from eraser.
4) On this drive I still have ntldr, ntdetect.com and boot.ini files. This drive should be bootable as I ran fixboot on it previously. To be sure I replaced these files with the new ones that I have now on my new master drive.

So the question is:
Why I still couldn't boot on my old drive? Nothing is wrong with it: has enough space:
- I set it as master again
- has fresh ntldr, ntdetect.com and boot.ini files, just as the new one.
- made fixboot on it so it should be bootable...

OK I can use my system as it is now but I am seriously concerned about the corruption generated by eraser (it looks like I am not the only one to get this problem) and I will not use eraser again until this question is adressed.
I don't think Eraser corrupted your system, this looks like a bug in the operating system. People have reported similar problems after using numerous programs that could not possibly have corrupted the hard drive (see Google). It is possible that Eraser triggers this bug, as it puts a lot of stress on the I/O subsystem by writing huge amounts of data to the disk. However, the problem can rarely be reproduced, so it's hard to tell.
I have been using Eraser for years and have had my system crash at least a half dozen times. Of course, I lost all data and files and had to start from scratch. Always received the same message, Cannot find NTLDR.

After the last crash, about a year ago, I checked the properties of the "boot.ini, NTLDR, and NTDETECT and noticed that 2 of the three files had not been checked as "READ ONLY FILES" I added the checkmark to make them "READ ONLY" and have never had a problem since then. No problems at all. Is this a fix? I don't know, but it seemed to eliminate any crashes associated with running eraser on my computer. Maybe you want to look at the properties of these files and check the read only status.

I run win/xp with SP1 and always keep it up to date via windows update. I noticed that some of the win/xp update files referred to making it harder to currupt certain windows system files.