Portable for 5.84?

When do we expect v5.84 to be available in a portable format?

I don't like installing such programs as a "giveaway" on my computer.
Hi windstrings :)

When you double click on the installer point it to your flash drive and Eraser will install there and also automatically use an ini file.
I'm on my work computer that I don't have Admin rights too... I downloaded to my thumbdrive and attempted to install from my thumbdrive to a directory I had set aside for it....

so even though I pointed the install to my thumbdrive, it still tries to install to windows32 the file "erasext.dll" which I don't have write access to, so I have to abort.

I also installs the name "eraser" to the program files.. I know I can delete it after the fact, but I wonder what other traces of its existence it leaves on the computer if I found that much even with an aborted install?

the install appears to be activated by windows installer which makes me think it also intended to leave an entry in the "add remove programs" which is not cool... especially on computers your not allowed to install to....

This program needs to be totally stealth..... the 5.82 version I have appears to be just that... I don't know why there is the need to have both a portable version and a installed version... seems the portable standalone would suffice for both.

Did I miss something?
Hi windstrings

I downloaded to my thumbdrive and attempted to install from my thumbdrive to a directory I had set aside for it....

I meant point the install “destination” to your thumbdrive. When you start to install the installer program should ask you where you want to install Eraser, that’s when you should point it to your thumdrive.
Sorry I wasn't clear, but thats exactly what I did!.....
It started installing, but then gave me the error saying I couldn't install that one dll file and asked me to cancel or ignore or abort.

It must not be able to run standalone if it has to have that file in windows\system32
Thats correct, its not working.

I may be because it wants to write a dll file into an area thats protected since I don't have admin rights on this computer.... it may install fine when I get home and can try it on mine.

If thats the case, I should be able to try the install again and choose to "ignore" that file and see if it works!..

It seems it would have to.
Hi windstrings

I would be very interested to hear what happens when you try later, please post back and let me know what you find out. :wink:

I should be able to try the install again and choose to "ignore" that file and see if it works!..

I don’t think it would work without that file, but give it a go ! :lol:
OK, I tried it again and I was right.. this is cannot be used as standalone.

it tried to copy these files to windows\system32 and I just told the install to "ignore"
1. erasext.dll
2. eraser.dll
3. eraserl.exe

It also gave me the same error as it tried to install to the windows registry... as I hit "ignore", I counted 52 times!
It would have made 52 entries in a normal install!

The install finished and then when I tried to run the program I got the erro that it could not write a value to the registry key ETC etc etc.....
Just give me a little time and I will try to sort something out for you. :wink:
Humm.. I don't see an edit function?

Anyway.. I forgot to mention, it did indeed also add an entry into the "add remove programs" in the uninstall portion of control panel.. it let me uninstall ok, but this would be unacceptable on a computer of which programs were not allowed....
I downloaded your file, I get an error when trying to open it that says its not a valid win32 application.

Its only 13kb in size.. maybe I didn't get it all.. let me try again.

I think that program they have that tries to open rar files for you is what messed it up...
OK, I got the whole tamale this time.... I saved it to hardrive.. that worked much better... anyway.. when I doubleclick on eraser.exe, I got the same message as the one when I installed it myself.

I appears you simply copied all your files and sent them to me?

The error I get is:

This application has failed to start because ERASER.dll was not found. Re-installing the appication may fix thie problem"

Looks like I"ll just wait till they come out with an upgrade to the portable version.
Hi windstrings

I appears you simply copied all your files and sent them to me?

No I made a portable version using the Eraser installer then zipped it up for you.

I first had to uninstall my Eraser (because you cannot run the installer again when there is already an Eraser installed) then I ran the installer and chose to make a portable version by pointing it to a new folder on my flash drive.

Then I tested it by using my flash drive version on my computer then my girlfriends to make sure it worked ok then zipped it up and sent it to you.

I am guessing because you don’t have administer rights that you cannot run .exe’s.

Also did you make sure you had uninstalled Eraser from your hard drive first ?
Yes, the previous version was uninstalled.

But my thumbdrive version "5.82" works perfect on this system?

I'm guessing that both yours and your girlfriends had the other version "installed" prior and so have the .dll files already that it looks for...

I bet if an when you uninstalled the previous version, the uninstall process didn't remove those files from the windows\system32 directory "or" the registry.

If you want to test my suspicions... look at the three files I told you install there and write them down... then uninstall your computer version and go and see if those files are still in your system32 directory?

If so, that would explain why it works for you as when ran off the thumbdrive, that version still looks for those files in the system32 directory.

I think I have worked it out.

When Eraser uses it’s own uninstall process it doesn’t remove the eraser.dll. I will report this as a bug. Also when installing to a flash drive the eraser.dll doesn’t get copied.

The other two files you mentioned do get uninstalled so this is not part of the portable problem.

I uninstalled Eraser 5.84 then rebooted. The eraser.dll was still there so I manually removed it. Eraser portable didn’t work, so then I copied the eraser.dll and put it into the same directory as the portable version was in. It then worked !!!!

So all you have to do is copy eraser.dll and put it in the same folder as the other files I sent you and it should work !

Phew, that was a toughy !
Nice Dick Tracy work!.... I haven't had a chance to see if it works.... I never got that file from you yet... How did you send it?

I am going to package the whole thing up for you and post a link for you here. I just have a couple of jobs to do and then I will get straight to it. Keep checking back here, I should have it up Monday !