Problem with DBAN and write-protected sector


New Member

I was attempting to format my hard disk using DBAN. One partition on my hard disk was password protected by muppet here forgot the password so I decided to just do a fresh install and be done with it. When I ran DBAN in verbose mode, however, it detects the HDD IDE drive and then gives the message 'write protected disk => 1'. It then stalls and will not continue. I know it works cos I have ran it before on my laptop with no problems. I then used Win XP Cd to format the disk. This was a bit weird cos it didn't ask me for anything, just started installing windows onto the disk. I rebooted, checked with DBAN (no luck), then managed to format the disk using the XP cd. I then tried DBAN again (no luck again - still write protected), so I formatted again using XP. Guess what? I tried DBAN again, with no luck. It still detects the drive as being write-protected.

Is there anyway to override the write-protection? Any help would be gratefully appreciated.
Sorry. It should of read 'but muppet here'. The term 'muppet' here is used in the derogatory sense as in you would call someone a muppet if he/she did something incredibily stupid. I did that hence I called myself a muppet. Please ignore it. :)
DBAN does not override this kind of glitch.

If you accidentally used an ATA command to protect part of the disk with a password, or if you used an ATA command to wipe the disk, then you must use the vendor diagnostic program to do an ATA wipe and unlock the disk.

You probably have a Western Digital product. If not, let me know the manufacturer and model of your disk.
It is a Maxtor DiamondMax9+ 120GB. I am going to give it another try this evening and see if it will work now that it has been formatted twice over using the XP disc.