Problem with Eraser installation


New Member
I have been using Eraser with no problems for some time. I received notice that it had recently been updated,
So I downloaded and installed the latest update, Eraser5.8.7. After it was installed, I received the following message:

The procedure entry point ?IsProcessElevated@@YA_NPAX@Z could
not be located in the dynamic link library Eraser.dll

Could someone explain why this is happening and how I may fix it.
I did consider a bad download, so I downloaded and installed a second time, with the exact same results.

Windows Vista Home premium
I am writing to report that I have solved my own problem.

I removed the program Eraser, rebooted, and then installed the updated version again.
It's working just fine now, and no more error messages.

I guess before we install an update, it's best to remove the old program first. Some software work that way, others don't.
Sure would be nice if they all worked the same. It's not always easy to remember which ones have to be uninstalled first.
Maybe the developer could put that little note in the installation package to remove the old program first? Just a thought.

Thank you,
Actually you don't need to remove the old version - just ensure that all instances of Eraser are shut down (including the ones running in the system notification area) that should solve the problem. I'll try to make a change in future releases, thanks!

Okay, will implement as part of ticket 213