Problems with wireless keyboard


New Member
I am having trouble starting the wipe process with my Logitech wireless keyboard. I can actually start the program from the 'boot' prompt by pressing the enter key, but after that, nothing I press works.

I have a receiver connected to a USB port for both the mouse and keyboard (both Logitech). I've tried pressing the 'reset' button on the receiver and then waited 20 seconds to press the 'reset' button on the keyboard (per Logitech documentation), changing the batteries in the keyboard, but no go.

In searching this site, I found a few references to USB keyboards not working due to a driver or an old BIOS. However, the keyboard and mouse don't come with a driver as this is a plug-and-play device, that also works in Linux as well (though I've only used Ubuntu). If this was a BIOS issue, pressing the return key wouldn't have started the program from the 'boot' prompt, so I don't think that's my problem, either.

Anyone have a solution?
Seems in my haste to post I forgot to mention what version of DBAN I'm using. Sorry about that, it's 1.0.7. I'm also booting the program from a CD-R disc.

Also, here's something else that I have found out. After I had posted, I t talked to a friend of mine on Yahoo Messenger who is familiar with the program and he tells me that I may need to enable 'USB legacy support' in my PC's BIOS.

'Once the kernel takes over,' he explained, 'It needs the USB module. The Linux kernel used here is very small.'

Well, I tried looking for that in my BIOS (Phoenix Award), but all I saw was two entries titled 'USB Controller', and 'USB Keyboard Support' - each both enabled already. No mention of 'USB Legacy Support' so my only guess is that it's not supported on my system.

So I guess I'll need to buy a PS/2 keyboard then, unless someone here has an alternative solution?
This advice is correct, and you probably found the correct option for enabling USB keyboard support in DBAN.

The DBAN 1.0.x releases requires that USB keyboards remain in legacy compatibility mode. If the change won't stick until the DBAN blue screen starts, then start DBAN at the black screen with the 'autonuke' option.