Program needs permission


New Member

I am running Windows 7 and am the sole user as administrator, have also Run as administrator and looked at FAQs. I have just installed Eraser and my first use is to erase all data on an external drive before taking it to correct a minor error. I deleted everything on the HD, reformatted it and then ran CHKDSK (No problems found). The steps used were: New Task > Run Manually > Add > Unused disk space > Chose one of the 3 partitions > Erase cluster tips checked > OK > OK > Rt clicked unused disk space > (E:\) Run now and immediately obtained the Status: Completed with errors > Rt clicked > view log > Obtained message: The program does no have the required permissions. Where have I gone wrong?

ItsBob said:
Where have I gone wrong?
At an educated guess, you did not close the running instance of Eraser before trying to run it as Administrator. This is explained in the FAQ topic on Getting to Know Eraser 6.

Hello David

Thanks for the very quick reply. I had already tried the method in FAQs but omitted to say so in my posting. Overnight my subconscious mind recalled a solution that works. Vista allowed you to open a Super Users account which was better than the administrators account. Microsoft kept this well hidden. I found that it is also available in Windows 7 and gave me the necessary permission. It is disabled by default and is enabled by a one line command. Google gave me several sites with instructions (Super Users Account) and I used howtogeek. I said it was successful but it is still running at the moment and will not be finished till after my bedtime. I will tell you if it does not finish successfully. I am not an expert and hope that I am not telling "Grannie how to suck eggs" but as this is a forum it just might be of use to other non-experts.

I'm grateful for your reply. As my daughter says, "Every day's a school day", and I didn't know of this option in Windows 7, no doubt because, as you say, it's not something that Microsoft have wanted to publicise. And thanks too for reading the FAQ, which is something we try to encourage.

In your case (now I know the circumstances), as you wished to clear the drive, I'd have begun by quick formatting it. This typically gets rid of whatever it is that is causing permissions issues, and also means that the option to erase cluster tips, whether set or not, will not come into play when you erase the free space (which, after the format, is all the space). I'd guess that, for most users most of the time, this is the easiest option, but the Super User option could be very useful indeed for the really intractable cases.

I think all is well but would like reassurance. I have tried both quick and normal format and receive the same message: Completed with errors. The log shows E: (or other chosen partition)\System Volume Information did not have its cluster tips erased. I cannot think that this matters but am not sure. If I uncheck the Erase Cluster Tips box the message is simply: Completed. If you can give me reassurance I hope you will then be able to live in peace!

You are quite correct. Generally speaking, messages about cluster tips not being erased do not indicate that there is a problem. Future versions of Eraser will probably downgrade most or all of these messages to 'Information', and will not include some of them at all. It is simply a fact of Windows life that cluster tips of system files cannot be erased.

I've also looked further into your tip about the Windows 'Super User' account. As far as I can see, this is the well-known facility to enable the Administrator account, which I think has existed since the days of NT. Unfortunately, the Windows Administrator account has nothing like the power of a Unix/Linux Super User, because there is also a hidden System account which owns all the system files, and which (for practical day to day running) is inaccessible even to administrative user; it can be accessed by very experienced people, but I really do not recommend this. That is why cluster tips cannot be erased on system files.

Thanks for the reassurance. I cannot see the need to check the Erase Cluster Tips check box if they cannot be erased. Running the program without it checked was very much quicker. I have just erased unused disk space on my primary drive and the log was completely swamped with messages saying the cluster tips could not be erased. I could not read the reason why because the message line was not long enough - even after dragging both ends.
Re Super User it is definitely superior to the normal administrator's account even though it is labled as Administrator. My ordinary administrator's account is labled Bob Administrator and I cannot get the required permission with this one. Hope I did not misunderstand what you were saying about the Super Users account!

Eraser does erase cluster tips, but not those of system protected files. That said, in my view this feature (to which some users attach great importance) does not add nearly as much to user security as the basic free space erase.

In Vista and Windows 7 (and this is a change from XP), user accounts with administrative privileges do not run as administrators by default. Even they have to explicitly run programs 'as administrator' (aka elevated). And even then, they do not have access to flles owned by the System account. The Administrator account always runs elevated (that is what it is for), but it too does not have System Account privileges. This is a far cry from the Classic UNIX Super User, who has total access to the system. IMO, it is a bit misleading to use the term Super User in a Windows context.

Actually, after Vista, even NT Authority\SYSTEM (the system "super user" account) doesn't have all powers. There are system files owned by "TrustedInstaller" which even SYSTEM cannot access (it's Vista protecting itself; 7 does the same)

This gives me reason to remove the warnings generated by system protected files. Such files are generally not modified (they are created at install time, which is quite difficult to have sensitive data in memory) except during patching/service pack upgrades (once again, you shouldn't be doing sensitive things -- the system is shutting down/booting up!) Unfortunately, I want to maintain the behaviour of versions int he same minor version (6.0.6 will behave lie 6.0.7 etc) so this will probably only be implemented for 6.1/6.2