recycle bin not erasing; admin login required

Edward Gelber

New Member
Using Eraser on Win 10 64 bit. I installed as an admin and as a regular user and got the same result: when I use Eraser to erase the contents of the recycle bin it says the job is complete but the items in the recycle bin are still there. The last version I had that worked was 5.8. Also, it requires an admin password to run. Is there a way to avoid this step?
I was having the same problem after updating to version today... Here's how I fixed it.

1) open Windows Explorer - click on View tab - click on options
2) click on View tab - scroll down to "Hide protected system files" and un-tick this - click apply
3) in Windows Explorer go to the drive of recycle bin you want to shred and open the $Recycle.Bin folder - e.g. C:\$Recycle.Bin
4) Now open the second "Recycle Bin" folder and copy the file path displayed in Windows Explorer (it is a long string)
5) open a New Task in Eraser, Type: files in folders - paste the folder path - un-tick "eraser folder if empty"
6) go back and hide your system files

hopefully this works for you guys