Registry permissions not being set correctly on install


New Member
I installed v5.84 with the install for 'All Users' option. When I tried to click the Eraser shortcut to open the program, I kept getting a 'Failed to restore preferences' error and then it would crash. I traced the problem to the permissions being set incorrectly (for me) on this registry key:

HKEY_CURRENT_USER\Software\Heidi Computers Ltd

This key wasn't allowing me to edit preferences because I wasn't "allowed". I even got this program on startup since by default the Scheduler is set to run. I had to right-click the folder of this key in the registry and check the 'Allow' boxes manually in order to fix it. This key (and a couple others in the registry, found from doing a Find for 'heidi' entries) don't get deleted upon uninstallation either. You may want to change that.

If I run the v5.84 installer and install it for 'Just me (the current user)', the program runs fine when I double-click. No manual editing of the registry is needed. No error messages.

Not sure if this is just a problem on my system or if it's a problem universally. Just wanted to report my difficulties. Great program otherwise.

- Steve
This is VISTA permissions. If you run Eraser.exe as administrator you can set the options without error.

As part of the next release we will be reviewing how the options are set and stored.