Required Permissions


New Member
I am running Eraser using Vista Home Premium.

I right click to "Run as administrator" but still get the following error when trying to delete unused disk space.

"The program does not have the required permissions to erase the unused space on disk.Run the program as an administrator and retry the operation."

Also, I am the only user on my computer and I have all administrator rights.

Can you advise what to do on this? Thanks.
Hi :)

Are you a beta tester ? Eraser V6 is in Beta at the moment.

If you just want to use Eraser then download this version.

Then turn off UAC.
You’re welcome. :D

Eraser V6 will be released soon’ish !

Please keep checking back or you can watch the progress here.
Actually I develop with UAC turned on now, so the correct thing to do is to exit Eraser (including the one in the system notification area, aka system tray), then right-clicking the Eraser shortcut and selecting Run as Administrator. I am of the opinion that UAC brings benefits to the majority of computer users, especially those less savvy and it is here to stay and for v6 I'm testing it with UAC on.

Of course, this new instruction only applies for v6, v5 may still not work properly (though it should)