right click menu in a 32-bit explorer


New Member
I enjoy using the software with no issues of any kind on my Win7 64 Ultimate machine. Thanks for the efforts!

Here's my Q:

I like to use xyplorer for my day-to-day housekeeping. It is only a 32-bit software, running on a 64-bit OS.
Naturally, I have no way to select a file and then invoke Eraser with a right click menu selection.

I use another piece of 32-bit software that I "tricked" by inserting its 32-bit DLL manually in the software's install directory, even though the software is operating completely in 64-bit mode.

Anything like that possible with Eraser? Thoughts?

Thanks for reading this!
A normal installation of Eraser places an entry in the Explorer context (right click) menu. I agree that this is much the most convenient means of erasing individual files and folders.

Is the context menu entry missing from your installation? If it is, fully uninstall Eraser, reboot and try reinstalling.

I've not tested it on anything other than Windows Explorer. If you really want to have a context menu, you can extract the Eraser install, and within you'll find a 32-bit (x86) installer. You can run the msi as-is.

I'm quite certain you can't have both the 32- and 64-bit versions installed at the same time, so you'd have to prioritise which is more important. The program works the same, nonetheless.
EXACTLY what I've done with other utilities on my machine. I will check this out and give feedback.

Thanks for responding.
You are right - it will not allow parallel 64 and 32 bit installations.

Next, I extracted the x64 and x86 .msi installers from the main Eraser installation program.

Then, I extracted all files from the x86 installer, and chose erasershelldll.dll as most likely the file I needed.

I tried simply leaving it in my installed 64-bit Eraser directory, and also tried registering the 32-bit dll with the system. That registration failed with program dependency errors.....no surprise there!

Ideas? I feel like I'm close - but just missing something stupidly easy, like dumping ALL the 32-bit dll's into the install directory, or creating a program files (x86) Eraser directory, with nothing in it but this one dll.

Firstly, apologies for not reading your original post as carefully as I should have done.

I think Joel meant (and this would certainly be my approach) that you could try running the 32-bit .msi file on your 64 bit OS (apologies if you knew this already, but just double-clicking on the .msi file invokes the Windows installer). My guess is that it would install normally (in Program Files (x86) rather than Program Files of course). However I would first remove the mixed installation as the manual changes might make a clean new installation difficult.

Does this make sense, or have I missed something?

way past that - tried that initially.

I know exactly what he meant: have the 32-bit dll present for a 32-bit application to find and use, even under a 64-bit operating system. Tried it and it works for other utilities, like Directory Lister Pro, which I have running as a 64-bit application but with context menus in BOTH 64 and 32-bit applications...

I extracted the 32-bit files from the .msi, even tried manually registering the appropriate .dll with the system, which balked due to Eraser.exe having been installed in its 64-bit mode.

I'm guessing erasershell.dll, in its 32-bit version, needs some special instructions to be "seen," and I just don't know what that is - having already tried manually registering it with the system.

If I get chewy enough with this, I'll try just using the 32-bit Eraser, assuming it will let me install that version on a 64-bit OS.
It will.

Chances are, though, that you are just missing the Visual C++ 2008 SP1 runtime.
It did install a 32-bit version on win7 64, if that's what I select.....

(I have C++ 2005, 2008, & 2010 redistributables all installed - I'm a gamer!)

But here's the punchline: if I install the 32-bit Eraser on 64-bit OS I do manage to get the right click menu extension I want in XYplorer, but I lose it in the native Windows 64-bit Explorer.

So, I pick the (slightly?!) better performance of Eraser 64 and just use the recycle bin context menu.

I appreciate your ideas. If you have any other thoughts, let me know.
The Shell extension doesn't depend on anything other than MFC and C++ Runtimes, which you said should already be installed on your system. So dependencies should be fully met. If they aren't, it would help if you could find out which one is not (the Event Log should have something to say)

You should try extracting the shell extension DLL to another folder on your computer and not the same folder as the 64-bit DLL.
I could not get eraser in the context menu on my 64-bit laptop. I wasted a great deal of time installing and uninstaling, using shellexview (which could not see eraser, in my case) and everything else.

What finally worked for me was choosing "instal on local hard drive" rather than the default "instal entire feature on local drive", under custom instal/extensions.
Which version of the installer is this?