Run as administrator


New Member
When I try to erase unused disk space on my C drive, I get the response, 'completed with errors'

I then get 'Error. The program does not have the required permissions to erase the unused space on disk. Run the program as an administrator and retry the operation.'

When I click 'run as administrator', I still fail get the same failed response.

How can I overcome this please?

Dave Light
Did you exit Eraser (from the system notification area) before running it again as an administrator?
I am having the same issue. I have a windows 7 64bit with an i7 processor. I tried to reinsall the program as the admin, I have also tried to run as admin and it does not solve the issue.

I am an administrator on the box but i susspect this is a windows 7 issue as i do not have the problem on my xp box
Please read my previous message and reply to that. That's always the cause of having seeing no difference when Eraser is started as an administrator. This includes the copy running in the background (in the notification area)
I have just downloaded Eraser on a new computer but it fails to erase unused disc space. I have tried 'run as administrator' but it still fails to erase. Any ideas please?

Please read the FAQ post "Getting to know Eraser 6" which explains the exact procedure for running Eraser as Administrator, and tells you where to find the task log (in case you have not done so already). If, having followed the procedure, you are still getting error messages (or the program crashes), please could you give details, and we'll take it from there.