Some files will not erase no matter what I do.


New Member
Okay, so I have some files that when erased turn up "Administrator Privileges Required" errors. So I run Eraser as an admin, and now I get "Access Denied" errors. I used FileAssassin to make sure the files weren't locked. Run Eraser again, and still no dice. I use v5, and I even upgraded to v6 to see if that would do anything. It didn't. My file system is NTFS, and I use Windows 7 Home Premium x64. Both versions of Eraser work on all other files, however it is these "special" files I'm talking about that refuse to erase. My Erasure method is the ol' good Gutmann 35-pass algorithm.
Administrator privileges are probably only required for free space erasures. Are you doing a file erase?

Depending on the file, NTFS permissions may still deny you access to it. What files are you referring to, could you give an example?
I am doing a file erase. An example of a file would be anything I download using Orbit Download Manager. If I download the same file using conventional or different methods, they erase. How do I bypass these NTFS permissions?

Edit: By anything I mean anything. Mostly documents, videos, and software/programs though.
Oh okay, Orbit download manager would fit the picture quite well. They download files as sparse files which Eraser cannot erase at the moment. Which version of Eraser are you using?
v6 would not erase sparse files to prevent disk corruption. v5 however should if the erase is done with administrator permissions. Oh, I'm guessing you erased usingthe context menu? You'll need to create a task in the elevated Eraser program and erase from there for the erase to go through.
Tried it. Didn't work. I looked up sparse files, and I see why they wouldn't be easy to erase. But, there has to be SOME way to erase them. Any ideas?
Could you detail how you did the erase and what error messages came up in the log?
I ran Eraser as an admin. Then, created a new task. Went to file erase. Selected the file. Then, ran the task. It failed, and all the log said was "Failed: [insert file path here]".

Edit: I didn't realize Eraser was updated today. I'll try the new versions.
Not that I know off, offhand. In addition, un-sparsing a file may leave the old sparse file unerased. Perhaps you can get Orbit to not make sparse files to begin with?
No option for that in Orbit unfortunately. But I dropped them a line, and requested they add said option. I doubt they will, but I use DownThemAll! now, which is actually better. In addition, it doesn't sparse files and it's a FireFox extension, so it's integrated right into the browser.
OK, I hope that brings some closure of sorts to this issue. Thank you.