The context menu issues

David L

New Member
I am using the most recent Eraser version, While it used to work in the past version, right clicking a file to erase still shows the Eraser option, but when I click on it nothing happens. I have tried "integrating into Windows Explorer" and using W. Expl, and have also tried with chrome and firefox. The option is there, it just doesn't do anything. Please help.
I suspect I know what the problem is but do not understand what you mean by "when I click on it nothing happens"? Rather than repost the same information, could you please read my response to Friday's post "Eraser needs administrative privileges to use?" and posts the answers back to THIS thread? It would be extremely helpful if you could tell me whether you LOGON with a User Id with Administrator authority? And, whether Eraser is authorized to run with Administrator authority as descibed in my response in Friday's post.

I would also like you tell me whether Eraser Auto started just after you did a complete Windows Restart by using the Windows Task Manager and check to see if you see "Eraser.exe" in either "Applications" or "Processes". Using Windows Explorer, try to "Erase" a file. You should get a UAC prompt asking you to allow Eraser to run with Administator authority UNLESS you have turned UAC off! If you have, I urge you to reconsider because it is a very great security exposure to run Windows in that manner! Using the Windows Task Manager again, is Eraser running? If it isn't, does Eraser even start when you double-click on the Eraser ICON on the Desktop? I don't think I can handle tonight dealing with Eraser not starting so I will assume that it has.

When you Open the Eraser Scheduler window (double-clicking on the Eraser ICON on the Desktop), you may see Eraser tasks queued for execution or which have been completed. Right-click on one, select "View Task Log" and check for any error messages. If none of them have run, right-click on one and select "Run Now". When it competes, check the "Task Log" again and see whether any errors occurred. If it appears that Eraser is functioning correctly, you too are just experiencing Auto starting failing because Eraser can run with Administrator authority (It must for some of its functions to work.) In that post I asked you to read, I reference a post I made in March that describes how to Auto start Eraser using the Windows Task Manager at LOGON. If you did, you would be able to use the Eraser Scheduler window (always accessible via the little triangle or Eraser ICON on the right-side of the Task Bar) to perform most Eraser functions without the UAC prompts. But, I repeat, if you disabled UAC prompts, please reconsider and turn them back on!