Two Issues Erasing an Entire Drive


New Member
I'm trying to erase several drives before throwing them away. I downloaded today and am using the latest version. I observed these issues when using it on the first drive:

1 After Eraser had finished, all of the folders in the root directory were still there. They were mostly (but not all) empty but the folders themselves had not been erased. Inside the Programs Folder it was the same situation -- the folders were all there and much of the files (maybe all) remained too. I was able to selectively erase most of the folders, but not all. Finally there were folders Eraser would not remove/erase, I had to use Windows delete to remove them.

2 Not knowing what might be left, since Eraser didn't remove everything, I tried to run Erase Unused Space to be sure. It came back instantly with "Finished with Errors". I was unable to find the error log for these errors. But, since it finished immediately it obviously didn't erase the unused space.

First, when one erases an entire drive should it remove all folders and erase unused space?

Second, anyone know why I got issues 1 & 2 listed above?

Edited to add this update:

On the next drive I decided to erase the unused space first, since it wouldn't let me do it last. I got the same response: it came back immediately with Finshed with Errors Obviously it hadn't written over anything.
When it comes back so quickly as having "finished with errors," I find I have to uninstall, reboot, reinstall, check run Eraser when it is finished, and it will work fine. It has always been that way in my experience. Don't know why, but it just does. But once reinstalled, it always works fine for me -- until the next time, that is.
I ran Eraser on an entire drive overnight and much of it remained (many files and folders). So, I did as you suggested . Then I tried to run it on the same drive again and, best I can tell, nothing has changed. It finished in about 10 minutes. When I checked many files and folders still remained. After two attempts to run Eraser on the same drive here are the Properties on one folder: