Unable to change context menu shorcut keys


New Member
I have a problem with Eraser 5.86a on Windows Vista. I can't change context menu shortcut key. I try changing shortcut key for secure move because i use rename alot. Whenever I try to change, it always says that I have to use letters from "Eraser secure move", even though I use letter from that string. I tried running Eraser as administrator and also in Windows XP SP2 compatibility mode but it didn't work. I even tried editing registry but I don't know exactly where it is (all I got was Eraser GUID in extension menu). Anyone have any idea how to solve this problem?
Looks like there may be issues with this option. I've just tried it here and it won't set a shortcut for me at all. I'll see about submitting a bug report once i've played around with it some more.

Did you remove older versions of eraser before installing 5.86a?

Can you perhaps turn off the shortcut option?
I've installed fresh copy of operating system Windows Vista. So the only copy of Eraser was v5.86a. After I couldn't change this setting I went one version lower. Basicall I ended up with Eraser 5.7 which doesn't have "Secure move" shorcut so I can use rename finally. But now I can't erase my Recycle Bin for example, also the some eraser options are missing.

The funny thing is that I tried same version (5.86a) on my laptop with Windows XP SP3 installed. And I could change the shortcut. Only on Windows Vista I can't and as I said, on Vista I tried everything (Compatibility, Administrator...).

As far as I can remember I could turn off shortcut option. But then with "Secure move" I lose also the option of erasing. Which is why I installed eraser in the first place (sure I could go run eraser scheduler and drop document inside...but I prefer an easier way if possible).
I believe I've fixed this in 5.8.7 in one of its betas. Can you try b5 and let me know if it works?