Unable to delete file: File is locked by another process

SD Gary

New Member
I am using Eraser 5.8.8 on a Windows 7 PC. It's worked flawlessly for years. As of yesterday, I am unable to delete PDF files using Eraser. I'm still able to delete other file types, just not PDFs. When I right-click, and select "Erase" from context menu, then select "OK" to start the wipe, I get a popup saying "File <path> is locked by another process..."

The PDFs are generated by either ScanSnap scanner, or my HP all-in-one. I've rebooted several times, so I'm not sure what process Eraser is unhappy with. I can "delete" the files no problem, and if I allow Eraser to queue up a wipe after reboot, that worksfine too.

The only things that happened yesterday were (1) Activated Adobe XI Standard (which hung my PC twice), and (2) CTRL-ALT-DEL exited a Eraser file wipe that was taking too long (inadvertently tried to wipe a HUGE file).

Is there a way I can determine what process is causing the problems with PDF files?