Unable to use Eraser on other Harddisk Drives


New Member
Greetings everyone, I have just recently set up windows 7 on a brand new harddisk drive. After installing Eraser, I tested and was only able to use it in C drive and the other partition (D drive) of the same hard disk, when I try to run it on the other 2 of my harddisks (tested and tried all 4 partitions) all gave me the same result.

"Filename" could not be erased because the file's permissions prevent access to the file.

I am not good with computers so when I right clicked the eraser.exe in the program file and select properties I am not sure what exactly to do regarding how to grant programs permission etc, this is also my first week with windows 7 and I am also unsure what all these administrative permission etc is about, it is very different from the days i run windows XP.

Is there anyone who can assist me in this so that i can run Eraser on all my Harddisk drives?
Have you tried "Run as administrator" also are these drives on a NAS or other network type storage?