Unhandled Exception


New Member

I've been using Eraser for a few years now with no problems. Today, while using V., I attempted to erase a file and received the error message "Eraser has stopped working...". I rebooted the system and tried again with the same result.

I did a complete uninstall, as per the FAQs, including deleting the registry keys and rebooted. I then downloaded Eraser, which seemed to install with no problems, but I got the same result when I attempted to run it: "Eraser has stopped working...". I was logged into the admin account, but just to be on the safe side I right-clicked the shortcut and selected "Run As Administrator". When I attempted to run Eraser again, this is what I saw.

Any ideas?


  • eraser exception.jpg
    eraser exception.jpg
    43.5 KB · Views: 357
Thanks Joel.

Didn't realize it was so old a bug. I should've done a more thorough search in the forum before posting.

It seems even stranger to me now, because everything was working perfectly on this box for a couple years; through every update and a couple OS reinstallations, too.

It seems to have started after the latest Win7/Java updates, if hat's of any help to you in racking it down.

Thanks for your hard work! I hope to be using the program again soon.
I've been patching my Windows 7 install along with Java, but Eraser seems to be fine...

After rebooting the computer a couple times, I attempted to run the program again and it worked! It still seems to be working properly, so I'll consider this problem solved.

Perhaps the box needed a reboot after the updates and I was not prompted to do so. Who knows? Just glad it's working again!
Alright, thanks. I don't seem to have the same luck with the bug though, haha.