Uninstall has detected that Eraser is currently running.


New Member
Unable to uninstall Eraser 5.8.7. I am using Vista, went to control panel, programs, tried to uninstall it, and it tells me "Uninstall has detected that Eraser is currently running. Please close all instances of it now" but it is not running. I checked task manager (showing all user processes) and it does not appear to be running. I rebooted, and immediately tried to uninstall, but again I get the message. Like a dummy, I then wondered if I could just install version 6, and maybe that would automatically remove the previous version, but that did not happen. Any ideas?
Solved it. Found the registry entry for starting up eraser when windows starts, deleted it, rebooted, and I was able to uninstall. Also, removed the reg keys that extend the explorer menu to use the eraser dll. I guess explorer had a handle on the DLL? How are people normally supposed to uninstall it if it doesn't let go of the eraser files?
You could just exit Eraser from the system tray area. I do believe that if the user did not run any erasures the Eraser DLL won't be loaded into memory (let me know if I'm wrong)
Nope, I made sure to even kill the process in task manager too, but something was keeping a handle on one of the eraser files, like the DLL or maybe an exe, but I think probably the dll got loaded by explorer
Hmm, yes that is a possibility. But that check is in place because previous installs caused corrupted Eraser installs (like missing DLL Entry points etc) so I wanted to remove that possibility in this new release. Perhaps we could include this in the release notes?