uninstall / install problem


New Member
I seem to have a problem when I try to uninstall , it's asking for an installation disk.
Never used one to install the software to begin with.
I tried re-installing on top, but same problem occurs, it wants a disk.

I can uninstall other programs no problem but not this one.

How do I solve this problem ? :(

Win 7 ultimate 64
This sounds to me like odd behaviour from the Windows Installer (needed for the uninstall). It may be that the uninstall script is damaged in some way. Try reinstalling Eraser without uninstalling first, and then uninstalling, to see if that helps.

It may be the Windows CD its asking for (Eraser is, of course, designed to be installed from a download). Again that would suggest an issue with the Windows Installer; some component of it may be missing or corrupt. Just to be sure, run a scan with your anti-malware, to ensure that nothing nasty has permeated your system.

Found what it's looking for
The installer package eraser(x64).msi is missing.
Can it be extrated from the Eraser file ?

Where does it normally installs itself to?
I think I just resolved this problem.
It appears to be a corrruption in the registry for this installation ,Could not remove or re-install this program.
I used an old Windows Installer Clean Up Application (msicuu.exe) and to my surprise it did cleanup the faulty entries in the registry.
I can now reinstall eraser 6. :wink:
Thanks for the info. The good news for me is that my next piece of advice was going to be to do a 'brute force' uninstall, which includes manually removing all references to Eraser in the Registry. I'm glad the clean-up utility worked for you; my experience is that they are a bit hit-and-miss in this context.

To answer an earlier question, The .msi files (32- and 64-bit) are both included in the Eraser install executable file. The .exe file simply decides which .msi file needs to be used, then hands that file off to the Windows installer to do the actual work.

You can use 7-zip or WinRAR to open the installer exe, it contains an embedded 7-zip archive which can be opened. The MSI can be found there.
Been following this thread. I have the missing msi file problem on my XP machine. What I don't understand from the posts here is how I get to uninstall - for example, I am told the msi file is in the exe. file - but what that means in terms of a solution to my problem is beyond me - what are the precise steps I need to take? - I have the exe. file and the 6.0.9 exe. file waiting in the wings to be installed.

Many thanks