upgrading from 5.8.8 to 6.0.7?


New Member
I am an occasional user of Eraser and currently 5.8.8 is installed on my Win7 64 bit notebook. I had trouble with previous versions of Eraser v.6 on this machine and went back to 5.8.8 because I wanted reliable stability for my occasional use. I looks like there is enough v6 stability and experience now with Win7 to upgrade. Before I do that, help me to understand what I need to delete if anything after Win7 uninstall of Eraser 5.8.8? I just want it to be smooth the first time.
A standard uninstall should be OK for Eraser 5; at least it always has been for me. But you could also delete any Eraser sub-folders you find in your Program Files and Applications data directories (the exact locations of which vary between OS versions and, in the latter case, depend on the user name). You could also run a Registry Cleaner (such as the one in CCleaner) to find redundant entries.

You should also look for any traces of the previous Eraser 6 installation; in particular, if there is still an Eraser 6 folder in <your user name>\Appdata\Local, delete it and its contents. Note that Appdata is a hidden folder; enable viewing of hidden files and folders to see it.

Hope this helps,

Humm.... Thanks for the suggestions. I followed them and installed Install seems to go correctly, but get message that "Eraser has stopped working, Windows is checking for ..." This error message is in a pop up that promptly disappears. The icon in system tray does not appear. I have uninstalled twice, deleted all Eraser files I could find, and cleaned registry with CClean. Each time I get the same behavior. I suspect that there is something with Win7 and security preventing proper installation despite seeming complete install. I have tried running Eraser as an administrator (right click on desktop icon) same error message. This is same thing that happened before and why I went back to 5.8.8 some months ago. Frustrating.... but I'll try to hang in there. Any more advice?
I have not seen your particular error before (and it isn't specifically documented on the forum, so far as I can discover), so this may be one issue where Joel is better able to help than I. But I do have one thought.

The only thing that I know Windows checks when Eraser is first used is the root certificates of the Eraser plugins. This security check essential to ensure that no rogue plugins have crept into your installation, so it is something you should be pleased about. But the check cannot take place if

  • Windows cannot get online when you first run Eraser (yes, it's another of those Windows 'call home' things);
  • your machine is not fully updated, and in particular does not have the latest set of root certificates installed.
Subject to other advice from Joel, I suggest that you go to the FAQ sticky on common Eraser problems, find the reference to root certificates and follow the link to the advice on this issue.

Don't know about root certificates. So far as I know all available Win7 updates are installed on this machine. This notebook was upgraded from Vista to Win7 in Jan. 2010. It is also running Norton Internet Security 2010. The installation seems to complete normally, but everytime I reboot, the message pops up for a few seconds that Eraser has stopped working. This also seems to occur every time I try to start Eraser. After these few seconds the popup disappears and then nothing. I am pretty sure the internet connection is working fine, other installations have worked OK and they check for updates, etc with no issue. As I said before no Eraser icon appears in the system tray. This seems to be because Eraser never starts properly. I tried to erase a file from Windows Explorer (ran as administrator), right clicking on file and then trying to erase. An exception occurs. This exception popup does not disappear but I can't figure out how to copy the text to give you more data. I'm not very skilled with Win7, mostly use XP.
Sorry, but on each occasion you post, I get a slightly different impression of what the actual problem is. Where does the 'Eraser has stopped working' message appear, exactly? Am I right in thinking that you aren't actually trying to run Eraser, the message just appears when you start the computer? Is there any other wording you can see on the message? Precise words would help.

Your latest post inclines me away from the root certificates issue, and more towards thinking that there are still elements of the original failed install on your machine, or that you still have a corrupt Task List in place. But I'd really like to know as much as possible about that error message.


P.S. You don't still have Eraser 5.8.8 on your machine, do you? It should have been fully uninstalled.
Sorry about not being so clear. Hopefully this helps. Eraser 5.8.8 was completely uninstalled. Registry was cleaned with CCleaner, and all files and folders with Eraser in name were deleted. I ran Windows Explorer as Administrator, searched whole C-drive and deleted everthing found. I had to do this as administrator in order to have permission to delete some of these files and folders. I then installed Eraser from SourceForge. The first time I ran the installer directly from the site. Everything seemed OK. Installation got to the finish button in the installer and when it was done all seemed fine. I rebooted and then got the popup with "Eraser" in the bar at the top of the window and the message: "Eraser has stopped working. Windows is checking for solution to the problem." A progress bar at the bottom of the window cycles a few seconds and the popup window then disappears and nothing further happens. I tried right clicking the Eraser icon on the desktop and running as administrator. After saying yes to the confirmation window allowing changes, I then get this same popup message again. It promply closes resulting in the same behavior as before. No icon ever appears in the system tray (as described as normal for Eraser 6 elsewhere in the forum). I also tried erasing a file from Windows Explorer running as an administrator. I got another Windows exception, but did not capture it at that time. I have not tried that since. I then completely uninstalled version 6.0.7 using Windows Control Panel, cleaned Registry, and deleted all "Eraser" files and folders as before. This time some files in Norton directory did not allow me to delete. For example a file in C:\ProgramData\Norton\{0C55C096-0F1D-4F28-AAA2-85EF591126E7}\NIS_17.1.0.19\Definitions\VirusDefs\20100621.022. Is issue maybe with Norton Internet Security? I tried installing again. This time electing to save the installer in a folder on C-drive. I ran Windows Explorer as an administrator and also right clicked on the Eraser file that was downloaded before and ran as administrator. Installation seemed the same as before. Resulting behavior was the same, except this time instead of rebooting first I right clicked the new icon and tried to run as an administrator. Same message. I completely uninstalled, cleaned Registry and deleted everything I could with Eraser in the name. Just before putting this posting together I downloaded Eraser again, saved on C-drive and installed as before to confirm what I said here. Same behavior again. Every time I reboot I get the error message and every time I try to right click on desktop icon and run as administrator I also get the message. I am accumulating exception files such as Report.wer in folder C:\Users\.....\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_eraser.exe_f33dfe0f7314fa888cbeb6df941ed1ecf68c_11ac1757.

I opened one of these in Notepad and copied here:

Sig[0].Name=Problem Signature 01
Sig[1].Name=Problem Signature 02
Sig[2].Name=Problem Signature 03
Sig[3].Name=Problem Signature 04
Sig[4].Name=Problem Signature 05
Sig[5].Name=Problem Signature 06
Sig[6].Name=Problem Signature 07
Sig[7].Name=Problem Signature 08
Sig[8].Name=Problem Signature 09
DynamicSig[1].Name=OS Version
DynamicSig[2].Name=Locale ID
UI[2]=C:\Program Files\Eraser\Eraser.exe
UI[3]=Eraser has stopped working
UI[4]=Windows can check online for a solution to the problem.
UI[5]=Check online for a solution and close the program
UI[6]=Check online for a solution later and close the program
UI[7]=Close the program
LoadedModule[0]=C:\Program Files\Eraser\Eraser.exe
LoadedModule[45]=C:\Program Files\Eraser\Eraser.Manager.dll
LoadedModule[50]=C:\Program Files\Eraser\Eraser.Util.dll
FriendlyEventName=Stopped working
AppPath=C:\Program Files\Eraser\Eraser.exe
ReportDescription=Stopped working

I hope this helps. Please if you have any new ideas please let me know. I will leave the existing install intact for now.
Thank you for describing your problem so fully. The failure to comprehend may have been all mine.

Firstly, the root certificates issue is, I believe, not your problem. I'm sorry for misleading you in that regard.

Secondly, by far the most common cause of the 'Eraser has stopped working' problem (of which your installation is showing the normal symptoms) is a corrupt Task List. At the risk of asking you to repeat yourself, please could you try to find the file

C:\<Your User Name>\Appdata\Local\Eraser 6\Task List.ersx

Note that Appdata is a hidden folder, so you will need to have viewing of hidden files enabled to see it in Windows Explorer. If you find the file, delete it, and try to re-start Eraser.

If that doesn't work, come back, and we'll try again.

I could not find any file named Task List.ersx . There was also no folder named C:\<Your User Name>\Appdata\Local\Eraser 6\ . I have enabled viewing system files and folders and can see lots of items in C:\<Your User Name>\Appdata\Local\... that are system files. Installation remains in same state as before. Please advise further.
Well, if the folder does not exist, that is your problem. The issue now is to discover what is causing it.

The first thing is to make absolutely sure that you looked in the correct User Account folder. When you are in your normal User Account, open the Run command (Windows key + R), and enter %LOCALAPPDATA%. From what you say, you should see no Eraser 6 folder in the Explorer window that opens; if do do see the folder, open it and delete the task list. If not, proceed as follows.

I assume that you are not preventing Eraser from running at start-up, which it needs to do. If you are getting the crash as soon as you install Eraser, that is not the problem in any case.

I don't know (Joel will) at what point the folder should be created; I suspect that it is when Eraser first runs, which would indicate that something is blocking Eraser from the outset. The most likely culprit is detritus from one or more previous Eraser installations. Sadly, this means uninstalling Eraser, and then doing a clean-up. Delete all files and folders (especially in Program Files) referring to Eraser, that you can find, then clean the Registry. If CCleaner is not finding the problem (make sure you use its registry cleaner, not its trace cleaner), try another Registry cleaner; there are a number of freeware cleaners available, and in my experience they all find different things. If you feel able to use the Registry Editor, open it and search on 'Eraser' (Ctrl+F to start the search, F3 to find the next instance); you can delete any keys that refer only to Eraser, and any values referring only to Eraser in keys referring to more than one program. Then try reinstalling.

Beyond that, its over to Joel, I fear.

If it still doesn't work for you, clean up the Eraser install (as reported earlier by David) and try a Nightly build. See if that brings you anywhere. First try the 6.0 branch; if that doesn't work, clean up again and install Trunk. Let me know how it goes.
Ok, I checked again for Eraser 6 file as suggested with winkey+r . There was no Eraser 6 folder. I then uninstalled and deleted all files with "eraser" in file or folder name. I ran CCleaner. Then I downloaded and installed v. . Installation seemed normal. When it finished I noticed that Eraser had not yet been started and there was no icon in system tray. I right clicked on desktop icon and ran as administrator. Immediate crash. There is still no Eraser 6 folder or task list. Clearly Eraser is crashing on first run before creating the Eraser 6 folder. When I try rebooting I get the "Eraser stopped working" message every time while booting up. Anything further to suggest?
bill735 said:
Anything further to suggest?
I'm sorry to sound like a cracked record, but the only time I have seen symptoms like this is when some residue of a previous failed install was present. Please forgive the stupid question, but when you ran CCleaner, did you run its Registry cleaner, rather than the main cleaner? The Registry cleaner, which is the one you need, is a separate function, which does not open automatically when CCleaner opens.

The next step is to look for Eraser-related entries in the Registry, as previously suggested.

Otherwise, I'm out of ideas, I fear.

Maybe you'd like to PM me your email address and I'll send you a custom build which will report crashes by default.
David - Yes, I used the registry cleaner in CCleaner. I will try regedit, but I have never done this in Win7 and it may take me a while to figure it out. When I do I'll try another uninstall and cleanup.

Joel - Excuse my ignorance but what is PM?
bill735 said:
David - Yes, I used the registry cleaner in CCleaner. I will try regedit, but I have never done this in Win7 and it may take me a while to figure it out.
In Windows 7, the Registry Editor works in exactly the same was as it has in every version of Windows since Windows 95.

bill735 said:
Joel - Excuse my ignorance but what is PM?
PM = Private message on the forum. Go to the User Control Panel (the link is in the header), and you'll find a tab for private messages. Joel's address is just "Joel", so that's easy enough.

Well I'm not sure what's different, but obtained from Joel is now working fine. I just uninstalled and cleaned up as before, but this time it worked with no problem when re-installed. No idea what's different this time. Thanks for your patience and all the time spent helping me. It was greatly appreciated. :)
bill735 said:
Thanks for your patience and all the time spent helping me. It was greatly appreciated. :)
We are here to help.

I too am using 2221, and as a development build it is quite stable. There are also new features; subtle but helpful changes to the UI, secure move and drive/partition erase among others. But, as with all development builds, some things need work (e.g. partition erase was not working for me when I tried it).

As you are now using 2221, may I suggest that you PM Joel and ask to join the Beta Testers' forum, so that you can report any issues with it there. Joel is pretty busy, so he may take a while to respond.

Thanks for the help. After uninstalling, cleaning registry, and all files with eraser in the name, Eraser is now working fine. Thanks Joel for the install file and guidance on creating dump files. Turns out a dump wasn't needed after this latest uninstall and reinstall cycle. Don't know why it worked this time and not before. However, this was the first time I went throught the uninstall, re-install cycle with this version. So far as I can tell I did the same thing as for the previous cycles. Anyway, all is fine now and I am going to leave well enought alone. Thanks for your patience in sticking with the follow up on my problem. :)