New Member

Eraser 5.86a for Windows 95, 98, ME, NT 4.0, 2000, 2003, XP & Vista (32 & 64 Bit) failed in multiple attempts (we did uninstall ver. 5.82 prior to attempted install of ver. 5.86a); and
subsequent attempt to re-install ver, 5.82 also failed as to context menu items -- i.e., no Eraser items display either on context menu or on drag and drop pop-up menu).


O/S = Win98SE ver. 4.10.2222 A Second Edition. No install attempted in the XP machine pending resolution of problem in the Win98SE machine.

1. After installing "EraserSetup32.exe" on Windows 98SE machines, and after completing the post-install reboot, we receive the following Error Message when we attempt to launch Eraser:

"The Procedure SHGetFolderPathA could not be found in the DLL SHELL32.dll." [Please obtain a new, etc.....]

Ersaser 5.86a does not launch at all. We did in fact obtain a 2nd copy; same result.

2. OTHER: a failed install of "EraserSetup32.exe" always leaves behind the following two files:

C:\Program Files\Common files\~0\ERASERSETUP32.EXE
C:\Program Files\Common Files\~0\mia.lib

[Note: we uninstalled and re-installed several times]

3. The failed installation must be cleaned up by hand in the registry inasmuch as the installation does not appear in Add/Remove Programs, nor is it visible in the Microsoft Install Clean Up utility.

5. No installation of ver. 5.86a has been attempted in the XP machine pending resolution of the issue in the Windows 98SE machines. Thus, we do not know if we would encounter the same problem in XP.

6. We re-installed Eraser ver. "eraser582setup.exe"; this version, which we had been using for several years in both the Win 98SE machine and in the XP machine with no problems, now refuses to display the Eraser options in the context menu for the following items that used to appear in the context menu for all files;

(a) Erase free space for the "drives" <drives only>;

(b) Erase <as to any file or directory>

(c) Secure Move with Eraser <as to any file or directory>.

In additions, Eraser no longer displays the "Secure Move with Eraser" option on the pop-up menu in a drag and drop move using the right mouse button.

Eraser DOES display, however, on the Recycle Bin pop-up menu and seems to work just fine.

The Main program seems to work OK; and the verify program worked when we tested it.

All files seem to be present; and "Erasext.dll" appears both at

"C:\Windows\System\Erasext.dll" and
"C:\Program Files\Eraser\Erasext.dll"

Both "Eraser.dll" and "eraserl.exe" also appear in the Windows\System folder.

Drives, files, folders, and drag and drop -- all in relation to not appearing on the context menu -- seem to be the problem, which is no insubstantial problem.

Our examination of the registry showed that everything seemed to be registered OK -- it's registered under "*", folder, driver, and also appears in the permitted shell extensions key values.

The only anomaly we noticed in the registry is that the installation of ver. 5.82 installs a retgistry key at "Heidi Computers Ltd\Eraser\5.5, which is a mirror image in all respects of the 5.8 key values. We do not know if this has always been the case inasmuch as Eraser v. 5.82 always worked perfectly, and, hence, we had no need to check the registry values for the app heretofore.

All other context shell extensions are displaying and working as they should.

The value for "ErasextEnabled" is set to Hex 1 -- 0x00000001 (1).

Installation file corruption does not seem to be an issue inasmuch as we re-installed from the same version 5.82 setup file, from the same CDROM disk we used in 2005 when we upgraded to ver. 5.82 -- no scratches or nicks on the CD; it's been in a protective wrap and case all along.

We are stumped. We can't go forward; we can't go backward to where we were before we tried to go forward (and failed). We've uninstalled and re-installed multiple times, cleaned any and all traces of Eraser out of the registry by hand and then attempted to re-install. Results are uniformly the same form of failure as described above with no deviation whatsoever in any attempt.

Keep in mind that Eraser always worked absolutely perfectly, in all respects, heretofore from the moment it was installed in 2005. We did notice one curiosity the day before yesterday, which is what prompted us to contemplate the upgrade to the next higher version, to whit: the "Move with Eraser" entry on the context menu for drag and drop disappeared; however, all other features of Eraser were nevertheless working as they are supposed to work.

There have been no new installs of any program or registry modifications to the machine in question for at least two weeks.

At this point, our predilection is to call it a day on ver. 5.86a and attempt to return to a working install of ver. 5.82 for the time being. We know that ver. 5.82 worked flawlessly up until the present time.

Any suggestions you may have would be greatly appreciated. If you need the actual, installation ".reg" entries, please so advise and we will post them here for you to examine or email them to wherever you tell us we should email them.

Thank you very much for your kind consideration of our request for support.

Best regards,


PS System in question is Win98SE, ver. 4.10.2222 A, Second Edition, RAM is 1 GB. (No problems encountered as to v. 5.82 on XP machine and no attempt yet made to install v. 5.86a on XP machine).
Addendum: I just noticed that the right-click, pop-up context menu now has a "new" item named "New Eraser Task Document.ers" document, just like it did prior to the attempted installs, re-installs, etc., described above. So, it looks like the problem on the re-install of the older version is confined to the "display" of the Eraser items on the context menu inasmuch as the installation program "seems" to have made the rounds through the registry like it is supposed to do, copied the files like it is supposed to have done, and placed an item in the "shell new" sub-folder with appropriate registry entries for file association. When I double-click the "new" document created by selecting the "New Eraser Task Document.ers" document type on the context menu, the Eraser window pops right up. So, darned if I know why the context menu display of the actual Eraser context items got left out (although they didn't really get left out inasmuch as they all appear in the registry where they are supposed to appear; they simply aren't being displayed)..

Is there any registry setting I can use to "force" the display of the Eraser items on the context menu. I noticed in the registry that the actual settings for the eraser all went in under the prime keys (in suplicate) between the 5.5 and 5.8 keys (under the Heidi Computers main key) and that the "settings" key had no values listed at all.

Sorry to have omitted the above information on the initial post; but I just didn't think to check the "new" item at that time.

Followup: We were able to install Eraser ver. Eraser 5.7 (July 25th 2003); it slid right in like a champ and seems to be performing flawlessly. It does everything we need to do, I think; so there is no need to spend any moderator time re-visiting the two later versions.

I am, however, curious as to why we couldn't install the ver. 5.82 again. Like I said, it worked perfectly for several years until the Eraser entries on the context menu suddenly went South.

We did in fact end up performing a registry trace on the 5.82; everything traced to where it was supposed to trace and all entries that one would expect to be present were in fact present.

I have not a clue as to why -- after seeming to perform a perfect installation -- the ver. 5.82 Eraser did not show up on the context menu but worked in all other respects.

If anyone has encountered this same problem, don't be shy about sharing your thoughts as to what possibly could have been the matter.

Alright, that was a very long post. Thank you for your descriptiveness. Before I continue further, however, may I ask why you are using 5.82? 5.86a was released a while back, and 5.87 will be released quite soon.

Can't find SHGetFolderPathA in Shell32.dll
I've checked my build configuration and checked with MSDN. I believe I solved this in the 5.82-5.87 timeframe, so 5.86 may have the fix.

Failed install of EraserSetup32.exe
I don't think this is the latest version, is it? Are you using a beta? We moved on to combined x86/x64 builds quite a while back (if memory serves, early this year)

Point 6, and thereafter
It certainly does look like you have a few installations of Eraser installed/uninstalled over one another. I don't have a 98 machine to test. I don't believe any installer within my memory would install the DLLs in two places. I've moved the DLL to the System directory for a while because of the presence of EraserL. The 5.5 and 5.8 keys further substantiate my hypothesis: Each version will only use one key. Having two keys means two different versions were run on the same computer.

What I suggest you do is try using a fresh Win98 machine and install 5.86a. I'm really interested to see how this plays out.

Thank you,