[v5&6] "Elevation Required" message while Erasing Free Space


New Member
Joel said:
No, don't move your desktop/laptop to a higher location, please. :D

You are running Windows Vista. And even though you are an Administrator, you aren't given God status until you tell Windows, look, I know what I'm doing, so leave me alone. By default, Vista assumes that you don't know what you are doing and so blocks what it thinks may be suspicious.

And Erasing Free Space is suspicious (though it is actually not, but Windows doesn't know that.)

That's what is meant by "Elevation Required": You have to look Windows in the eye and say "Let me have my way". To do that, close Eraser (check that no Eraser is running in your system notification area (a.k.a.system tray), then Right-click on the Eraser shortcut either on your Desktop or in the Start Menu and select Run as Administrator. There should be a little shield beside the menu entry.

Then run the task again.

Hi. I found your site on Google. I am having serious problems with eraser and vista. I am seriously considering either
1. throwing my laptop in the garbage
2. taking the HD out and shattering it with a hammer
I have tried all of your instructions above....nothing has worked.
Any other ideas?
By the way, didn't eraser use to have a single file shredder? what happened to that feature?
Re: [v5&6] "Elevation Required" message while Erasing Free S

And... what is the problem you're seeing? How do you know it doesn't work?

Files can still be added to Eraser for erasure. Have a look at the documentation, which include screenshots and step-by-step instructions.