What happened to Eraser?


New Member
A few months ago, I upgraded to the most recent version of Eraser:

Today, I fired up the program to do some disk cleaning maintenance...

- files appear to have been erased.... but directories have not. That's a bug, a real one.
- the progress bar has gone............ not an improvement, in my view. To the contrary.
- the 'complete' notification ........... fails to trigger occasionally (when directory is empty?)

FYI, I am running Windows 7, 64-bit.

If directories are not erased, Eraser has lost its usefulness.
Although, Eraser is a free program, I do appreciate the work the developers put in, and (a long time ago) contributed to its development/maintenance.

I am very sad. Perhaps I can find a previous copy in my backups, and hope it runs under this OS.

I downloaded the latest version two days ago and tried it out on a small external hard drive, before I threw it at the main 2TB monster, and found none of the problems that you mentioned and, like you, I am running 64bit W7.

Good luck with it.

I also tried erasing directories, it works fine on my computer.
The progress bar is now hidden, you can get it by double clicking a task while it runs
The complete notification can be blocked by you in Windows' notification settings.