Why doesn't Eraser erase the file?



Hi, have been using Eraser for quite a while. Today I found a file restoration tool and I wanted to test whether Eraser actually does its job properly. Using Windows Explorer, right clicking a file and selecting Erase the Eraser dialog w/ progressbar appears (as it always has) while erasing the file. So far so good. I then ran a freeware tool called Restoration (http://hccweb1.bai.ne.jp/~hcj58401/) and searched for the erased file. It found it (!) and was able to restore it properly(!!). The restored file is identical to the file before it was "erased". Eraser Options are default with 4 erase methods (I have not edited them). What gives? Why doesn't Eraser actually erase the file? Can anyone duplicate this behaviour?
Additional information:

Running Windows XP SP1, Eraser version 5.7
I cannot reproduce the problem. Erased files cannot be recovered with this program, as was expected. Did you get any error messages from Eraser, or have to turned off the result window?
I have NTFS. I had all reports turned off. I turned them on and tried the same erase procedure. Now it works, the file is not found by the restore application. Turning off reports again and it still works...
I am now unable to reproduce the error I could reproduce earlier today.... Hmmm :?