Win7 usability issue - UAC


New Member

may be already aware of this:
When installing Eraser on Win7 it places the systray app to the tray, and it is running with user credentials.
When I tried to erase something, I got access denied, due to sufficient privileges. In order to get it work, I had to close systray app, and run it again with admin rights. Then it worked.
So, the tray app should run with UAC request at the beginning. Just for a suggestion.

It is, in effect, already planned. For further information, see the 'sticky' thread on Eraser architecture in the FAQ. But Windows doesn't make things easy. Essentially, what is needed is not so much permanent elevated running of the program but further development of the architecture to remove the UAC constraint, and also deal with permissions issues (Windows can have a mind of its own in allocating ownership of files).

For the present, I'd take the view that the user should be aware that they are running the program elevated (because this is by no means always necessary), and the relatively minor inconvenience of having to do as you did is a reasonable price to pay for this knowledge. The real issue is about enabling users to know what they need to do (which, fortunately, you already did) in order to run the program as Administrator. There is full information in the FAQ, but the number of posts on this subject in the forum suggests that many people just do not look there :( . If they don't look in the FAQ, I guess that they're not going to read the manual, either :( . Let us hope that 6.2, when it finally appears, will reduce the number of posts on this issue ...

You can't get Eraser to start with Admin rights off the hook because that would prevent non-admins from using Eraser at all.