Windows 7 x64 HD corruption


New Member
I know Eraser 5.8.7 isn't officially supported on Windows 7, but I have successfully been using it for a few months now, first with the Win 7 RC's and now with the RTM.

But not any more, I'm not sure what changed (I've not installed any new software), it might be due to the Windows 7 fix roll-out last week, but I've had TWO instances of partition corruption using Eraser 5.8.7. One totally unexpected, and the other after I restored from a backup and tried to find out what happened the first time.

The first time it happened I was attempting to erase files (with a single pass random setting) from the desktop with the explorer context menu, it managed to get through a few then the program stopped responding and crashed Explorer. After restarting and trying again, I got an access failed error on the erase. I proceeded to delete the files normally, (ie. putting them in the recycle bin). Then attempted an erase of the recycle bin. Again Eraser interface hung, but apparently continued running in the background, I couldn't terminate it with the Task manager. Explorer crashed again.

Upon restarting the system, I get a 'Operating system not found' message. My C: partition is now identified as RAW format, the D: partition on my drive is untouched.

After reinstalling from a backup, I tried to erase some files with the portable command line version of, again I got an access denied error for no reason,I then moved the files to a location that I've set to erase automatically at shutdown (using the portable command line version), hoping it would remove any access problems. Upon reboot 'Operating system not found'.

People have posted similar problems in the past when dealing with encrypted files on Vista, this obviously is a different problem, but with very similar hugely frustrating outcomes.

I'm not here to whine, but to warn people of the dangers of using this software on Windows 7. Hopefully someone knows why this would happen and can be fixed
in the new versions.
It's caused by the file being set as sparse and using a first/last 2kb erasure if I remember correctly. What erasure method are you using? This I believe is fixed in 5.8.8-beta1. how did the files get to your desktop?
Erase method was either first/last 2kb or Random pass, hard to know which one broke things

The files were just documents downloaded off my file-server. No reason they'd be sparse.

I believe something else would have caused the crash.

At any rate, until Eraser gets a big Windows 7 x64 approved stamp, I'll be using something else, which is a shame, I've been using Eraser a many many years now, nothings ever been as good.
It's probably the first/last 2kb pass. That was a reported bug. It affects all versions of Windows not just 7. You can keep using it, just don't use the first/last 2kb pass (or use 5.8.8-beta1 which has the bug fixed.)
I installed the Beta version today to see if it works. Gave me the same problem. I was testing with a single random pass. It doesn't corrupt the partition straight away, just when I persist on Erasing the files after the process has hung. If I let the hung process continue that's when things start breaking badly. Windows wont/cant respond to the hung process, so I have to power off the machine to make sure my drive partition stays in one piece.

I've got very few memory resident programs running on my system and doubt that any of them would be interfering with Eraser.
Perhaps you'll like to try the v6 Beta. That should work (the overwriting algorithms are different from v5) and I run it on my Windows 7 RTM computer regularly.
This is the wrong forum to post this. But in any case, no. Aero Shake is a Windows 7 feature.
Congratulations on the release of Eraser 6 Stable! I am installing it now with hope it's fixed my previous problems.

Thank you for all your hard work over the years it's greatly appreciated.