Windows 95 error on Eraser missing Kernel32.DLL


New Member
Hi, I am unsure if I should have posted to the “bug” forum instead. Please let me know and I’ll re-post to the proper forum.

I had downloaded EraserSetup32.exe from and it was installed on my XP machine and as far as I can tell it has properly wiped clean the free spaces on my hard drive. I just began installing and using the Eraser yesterday so haven’t had much time yet to explore all its capabilities.

I, however, have a Window 95 machine and ran into a DLL problem (see below) after I’ve successfully installed Eraser. I should mention that the W95 machine is at the “4.00.950 B” level. It lacks internet access, USB ports, etc. I would very much like to use Eraser to wipe the data before I give the machine away.

On starting Eraser, I received the error message "The MSVCR80.DLL file is linked to missing export KERNEL32.DLL: Get LongPathNameW. I don’t understand why the Kernel32 file is missing, because it is in the Windows\System folder. In any case, I exited the message and tried starting Eraser from Start/Program File. On this attempt, I received 2 messages: one described before and another saying "C:\Program Files\Eraser\Eraser.exe A device attached to the system is not functioning." I rebooted hoping that it would solve the problem, but continue to get the MSVCR80 error.

I uninstall and reinstall Eraser with same result.

I next tried finding the 2 files in the XP and in the W95 systems. The MSVCR80 has the same length on both systems and the dates created are about the same. But, Kernel32 is smaller, by almost half, in the W95 than in the XP. I thought I give it a try by copying the XP version of Kernel32 to the W95. I got a black display when I rebooted, so that experiment failed badly. The machine worked, however, when I put the original Kernel32.DLL back into the W95 system. Phew!

Before posting to this forum, I double checked to see if W95 system is being supported by Eraser and it says it does. Just checking so that I don’t look completely like a fool. In any case, I think there’s an incompatibility issue involved and I hope my above details provide some clues to solving my problem.

Thank you in advance for your help and a VERY HAPPY NEW YEAR!!!

Windows 95 eh ? :roll:

I would very much like to use Eraser to wipe the data before I give the machine away.

If you want to completely wipe the entire disk then DBAN might be better for you.

Be warned though DBAN will wipe the ENTIRE disk so if you want to keep anything then you need to back up ! :shock:
5.8 binaries won't run on 98 - that's because they're compiled with Visual Studio 2005 of which the runtime does not support Windows 95. You'll have to use 5.7.