wiping an external, networked hard drive


New Member
I have a small (160GB) network storage device which I need to RMA to the manufacturer. I'm trying to use Eraser to wipe the entire drive (it's all "free space" now since I deleted the files).

The drive is normally accessed as a network (TCP/IP LAN) share device. The Eraser explorer doesn't see the device... only the C: drive. I tried mapping the share to a drive letter, but C: is still my only option. The "Erase" option doesn't appear when I right-click on the drive. The device only has a LAN connection (wired or wireless)... USB connection is not an option.

Why can't I erase a networked storage device?
Wiping free space on a different hard drive over the network would be a cool option. I've tried doing that with a different product called BCwipe and it works, but the only problem is it takes forever. I wiped the free space using <1-pass random>, but what I think was happening is the the computer I was sitting at was generating the random characters and sending them over the network to the other hard drive. So wiping a remote 20G hard drive was the same as copying & pasting a 20G file from my computer to the remote hard drive. Probably would not disrupt other users on the network that much if you use a switch, but if you were just using a hub I would say forget it.