[Bug:] Problem with Shell Extension (right-click context menu) on Windows 10, 64bit


New Member
I am having problems (probably a bug) with the Shell Extension of build on Windows 10, 64bit.

I first installed the latest "Eraser6.2.0.2970.exe" from Sourceforge as an Administrator (the system would notify me that the runtimes included are not needed, so I just hit "Close" and the installation would pass through successfully).

The context menu appeared in my Windows Explorer screens - however, erasing files from the right-click menu would only work when I was not logged on as Administrator. I.e. it worked only in accounts different from the Admin account.

In the Admin account itself, the context menu itself would appear but after clicking on "Erase" nothing would happen. Then, after restarting Eraser manually, the built-in BlackBox Report plugin would always show the following Debug information:

Exception 1:
Message: Could not load file icon from W:\
Exception Type: System.IO.IOException
Stack Trace [0]: at Eraser.Util.ExtensionMethods.Methods.GetIcon(FileSystemInfo info)
Stack Trace [1]: at Eraser.DefaultPlugins.UnusedSpaceErasureTargetConfigurer..ctor()
Stack Trace [2]: at Eraser.DefaultPlugins.UnusedSpaceErasureTarget.get_Configurer()
Stack Trace [3]: at Eraser.Program.TaskFromCommandLine(TaskArguments arguments)
Stack Trace [4]: at Eraser.Program.CommandShell(ConsoleArguments args)
Stack Trace [5]: at Eraser.Program.CommandMain(String[] commandLine)
Stack Trace [6]: at Eraser.Program.Main(String[] rawCommandLine)

Guessing from the above Debug information, my specific problem seems to be related to a drive (the W drive) that is mapped as a network drive in my Admin account (but not in other user accounts on the same machine), and from which Eraser obviously tries to retrieve some file icon that causes the IO exception.

Can this problem be fixed somehow by building in some error handling or so when a file icon (here for a mapped network drive) cannot be found?
PS; I also tried the "Eraser6.2.0.2971-NoRuntimes.exe" (or the contained "Eraser (x64).msi" respectively. Here, the context menu would not appear at all, not even ater reinstalling/repairing/trying different custom installations.

Did anybody get the context menu to work at all in Win 10/64bit by using this installer (2971)?
I have done some further testing and can now confirm that the problem described in OP is a bug.

What I did is to unmap the network drive in question ("W:") from my Administrator account so that it does not automatically re-connect at startup
- Result being that now the context menu is working as expected, without the above IOexception.

After manually re-connecting the network drive, the exact same problem pops up again, as confirmed by the above exact same Debug info from the Eraser BlackBox Report. Once the re-connect is done, I cannot get rid of the error again.

EDIT: When I manually disconnect the drive again using Windows Explorer (I did this via a Commander tool before), everything works fine again.

So I guess this thread should be moved to the Bugs forum, or whatever the process for this may be...?
Last edited:
BTW, the icon in question comes from a file management application that does the drive mapping and brings along its own icon for network shares managed with that application. So it may help to do some further testing with other icons possibly used for Windows network shares / that are injected by related applications (e.g. Sharepoint, ...?)

In any case, an exception handler whatsoever would be needed and built into Eraser to stop the Shell Extension from crashing in such cases.