Eraser 586a Released

Not open for further replies.
Hi Garrett. :)

I notice you are working late into the night ! :lol:

Thank you for your efforts, I don’t have 64bit but I will PM some members who do to get this tested for you.

Hi, I appreciate all the help for us 64bit vista users...but I still get an error. Also I have no way to uncheck the 32bit install..I can only uncheck the add Eraser to the recycle bin entries area, (see the 32bit core install box is completely grey)

Also I notice on install I have the visual C++ install 2 times of which is 64bit.

I do not have UAC enabled as it such a pain.

I tried installing Eraser with and without unchecking (uninstall and reboot inbetween)...and I get errors.

This Is best I can do by unchecking...the 32 bit only has grey box

This is the error

I was hoping I wouldnt have to report bad you all are working hard on this.
PS...On removal of Eraser and Both C++ entries in the add/remove programs section, I get an error removing the 64bit C++ its wording I thought I should post the capture....

PS...Sorry about posting big captures..but this way you can see what im trying to do...and see the problem as I do.
Hi Blewby

I am sorry to learn that things are still not working for you.

Thanks for your input though and I hope you will continue to help test the 64bit version.

You bet I will...Between Joel and you, Overwriter.. I will help test...I know Joel is working hard with a non Vista 64...and Garrett is helping with the 64bit...with my posts I hope I can help?!?

This is a great App. to have, but the Portable 5.84 version is still the only version to work with Vista 64 (at least for me).

Like I said in previous post...I hope the pics are not irratating..but I just want to show you all what I see.

Thanks All and Hope you have A Happy Holiday season!
Do not uninstall the x64 and x86 redistributables. This may prevent other programs from working.

Is installing the 32 bit version a hassle for you?

Like I said I'd really wish to get an x64 build if anyone can point me to the right direction. I can't find a link to contact Microsoft Singapore for a copy.

Hi Joel

I tried first to install Eraser 5.86a completly with all items checked and got the error..Then uninstalled/reboot and tried installing with 32bit unchecked. I guess this really is no biggie as the portable is working well..but im here to try to help.

As far as linking you to a site..I found this in microsofts-Singapore's site... ... tobuy.mspx
Im sure you seen this also tho. If your looking for a site for MS to 'handout' a copy for program developers I do not see anything.

The redistributables only show when I install Eraser...not sure if any of my programs rely on it at all (everything works fine yet without it except the X64 redistributable is still in add/remove as its stuck there). I was just trying to do a clean install before reinstalling Eraser, also did a regedit. Tried everything I could do to try to make it work.
Not really developers' handout, more like something a legal owner of a copy of Vista would have an entitlement or something to a 64 bit version...

Hmmmmm I really have no idea how to help from here.. Never used a 64 bit OS before

Even though the x86 boxes check-boxes are cleared (but one remains greyed like blewby says), on the next screen prior to installation I can clearly see that it says (something like) "install components selected - x86 and x64".

Is this the problem?
This is the error [img said:[/img]

I was hoping I wouldnt have to report bad you all are working hard on this.

I get this error on Win32 vista.
I'm using XP Pro x64 on a dual core AMD machine. I was also receiving the "misconfiguration error" message after installing 5.86. Using the separate 64 bit installer solved the problem. One slight bug noted in this separate 64 bit distribution. The Start Menu item for Eraser Verify is set to the wrong executable name. When Windows Explorer starts it's "looking for this item" dialog, its easy enough to hit the "browse" button and select the Erschk.exe executable. After that, everything works correctly.
I'd be happy to help with an 64 bit testing. I normally run XP Pro x64, but I also have machines running Vista x64, Vista 32 bit, and XP Pro 32 bit.
Hi Garrett,

I attempted to install this (Vista 64) im getting the error

Eraser.exe-Unable to Locate Component.
This application has failed to start because Eraser.dll was not found. Reinstalling blah blah blah...

Man Im Starting to think its me...or my machine. I just built it 3 weeks ago but all other things work great...exspecially when Nvidia released there last graphics driver.

I will see if I can locate Eraser.dll (post back later)

Found Eraser.dll in C:\Windows ...where should this be moved to?
This version posted by admin installs and works for me on Vista x64. Thanks for your persistence!

Only thing now is that Verifier is not included with this installation?
Not sure why but my Vista 64's(my last computer and now this new build) had this problem with most Erasers it purposly misplaces Eraser.dll in wrong spot.

I remember using I believe it was 5.85beta 2 and that one actually installed and worked well (wish I would of kept the exe file)...and also I had the option not have all the Recycle Bin option's.

Also Im not to sure how Eraser 5.84portable works but that works well on both my vista 64 machines. So im faithfully using them...and hoping they work as well as the installed version.

So...How or what can I do to make sure it places Eraser.dll in right location. It was installed but in folder C:\windows but when I start the program it says Eraser.dll is not found or missing component.

Also If I could make a request to have yes/no to recycle bin options again?

Thank You All for your help with my and Vista issues...I do see hqdub has vista 64 and Eraser is working there is hope :D
Verify is now renamed ErsChk.exe as verify is a reserved DOS word.

Eraser.dll,Erasext.dll and eraserl.exe should be installed in your system directory.

I suggest you uninstall all copies of eraser and delete and dll's/exe's then reinstall the version from the site. - let me know how that works.

I have re-released the installer with some minor changes- download again.

Hi Garrett,

As you requested feedback..

I appreciate all the help and see you are making Great improvments with Vista 64bit users, as Hqdub's machine is reported working well with Eraser. ..However my computer is apparently fussy, and I get the same Eraser.dll is missing altho when I do a search it IS installed in the system directory.

I installed your latest 64bit app, after uninstalling, search & delete, regedit and reboot. But I get the same Eraser.dll missing error.

I will be slim on my posts as I do not want to deter any Vista users from using this app. I will keep using Eraser 5.84 portable, and also keep trying to install new releases. I WILL post back when my computer thinks I am 'worthy' of running Eraser :lol: Sidenote...UAC has been disabled the miniute Vista installed.

Thank you ALL for your help...Garrett, Joel & Overwriter
Hi Blewby.

Blewby said:
I will be slim on my posts as I do not want to deter any Vista users from using this app.

I personally would like you to keep reporting in. The more feedback, positive or negative the better. Development is slow without quality bug reporting so please continue what you are doing to help get Eraser fixed.

Not open for further replies.