Eraser crashes immediately


New Member, Windows 7

After installing Eraser as admin and checking the "run Eraser" box I get an immediate pop-up: Eraser has stopped working. Windows is searching for a solution to the problem.

Trying to delete a single file in explorer I get: Eraser cannot connect to the running instance for erasures.

Trying to delete a directory: Same thing.

Any ideas?
There's a fair chance you've had a 6.1 build working on your machine. If so, see the sticky thread about installing 6.0 after 6.1 at the top of the forum. If not, still see the same thread, and use the instructions there to delete your Task List. Then re-start Eraser.

I have this problem on XP. I even went through the steps in the documentation about completely removing Eraser from your computer. This occurs with all builds of 6, but does not appear with 5.8.8
In XP, you need to look for file %USERPROFILE%\Local Settings\Application Data\Eraser6\Task List.ersx, and delete that. Viewing of hidden files and folders has to be enabled for you to find the file.

Your symptoms are exactly those I would expect if you have a corrupt or otherwise bad Task List, so it's best to be sure that you really have deleted that file before looking any further.

abbadon said:

I just installed the new build Eraser (uninstalled the old version, deleted the tasklist, removed the key in registry, rebooted and installed new build).
Eraser starts. But when I'm trying to erase files I get this error:

  Stopped working

  Problemereignisname:	CLR20r3
  Problemsignatur 01:	eraser.exe
  Problemsignatur 02:
  Problemsignatur 03:	4bdef85c
  Problemsignatur 04:	Eraser.Manager
  Problemsignatur 05:
  Problemsignatur 06:	4bdef856
  Problemsignatur 07:	145
  Problemsignatur 08:	a
  Problemsignatur 09:	System.InvalidOperationException
  Betriebsystemversion:	6.1.7600.
  Gebietsschema-ID:	1031

A bit confusing: I tried several times to delete files via context menu, drag and drop and new task in eraser. Sometimes it worked (also with files eraser crashed before) but mostly eraser crashed.
Join the Eraser Beta Testers group and post to the Beta forum, let's take this offline.

Also, please enable the BlackBox plugin and post the debug log. I'll fix the uploads later.
I have the same problem in XP Pro. with Eraser

I don't have a task list file (or Eraser folder) under any Documents & Settings folder. I also tried using regedit to remove any eraser entries prior to installation.

It crashes if I use either the Programs shortcut or the trash bin Explorer extension.

Any ideas?

The Task List.ersx file is not in Documents and Settings; in XP, it's in the path referenced by %APPDATA%. I can't get to XP at this minute, but I suggest that you do Start|Run, then type in %APPDATA%. Explorer should open in a folder which will contain an 'Eraser 6' folder. Go there.

Note for Vista and Windows 7 users: the path is referenced by %LOCALAPPDATA%.

XP is at C:\Documents and Settings\User Name\Local Settings\Application Data\Eraser 6\
When I was having this problem, I didn't have any ersx files on my entire computer. I think what solved the problem was that I didn't run Eraser immediately after restart. I let the installer completely finish, then I fired up Eraser once it had closed. I can't think of anything that could have changed between when it didn't work and when it did, so try that
Thanks for the suggestion, but no joy. I also tried installing it without the Explorer extension, same result.

As I mentioned before, I have no Eraser folder at all under App Data in XP after installation. Should that be created during installation or during the first run?
enoch said:
I have no Eraser folder at all under App Data in XP after installation. Should that be created during installation or during the first run?
Yes. The folder is 'Eraser 6' The %APPDATA% folder is hidden, so you have to have viewing of hidden files enabled to see it in an Explorer tree. But (I think this also applies to XP) entering %APPDATA% in the Run box will always find it.

It's not %APPDATA%, it's %LOCALAPPDATA%.
Joel said:
It's not %APPDATA%, it's %LOCALAPPDATA%.
Yes, for Vista and Windows 7. For XP, we were both wrong; I now find that XP does not recognise %LOCALAPPDATA%, and, using an environment variable, the path is %USERPROFILE%\Local Settings\Application Data\Eraser 6.

im also having the same problem with eraser crashes immediately when i open it.

Eraser, Windows xp sp3
Did you do as suggested above? And what error message, if any do you get?

Yes i did the what was suggested twice,

Here is the error signature
AppName: eraser.exe AppVer: AppStamp:4bbfca0e
ModName: mscorwks.dll ModVer: 2.0.50727.3603 ModStamp:4a7cd88e
fDebug: 0 Offset: 00097d9a

and when i open eraser it doesnt show the application it just opens up the cmd promp window
I'll leave this one to Joel. If I were guessing, I'd say there was an issue with the dot NET runtime, but I might be way off.

Did you have any other version of Eraser installed on your computer?
i had the last stable update but that started to crash so i downloaded the update, but now it will only work if i unistall,reinstall evrytime i reboot my pc