Eraser doesn't want to start at all


New Member
Hello, I apologise if this is the wrong forum for this kind of issue.

I'm having trouble getting eraser to work at all. It worked for me correctly few weeks ago, but then out of the blue it stopped working at all. Whenever I try to run the exe, or even use the shell integrated functions all I get is the loading cursor for a few seconds and nothing happens.
The eraser process is active for a few seconds, then it dissapears. I'm not getting any errors at all.
I've tried uninstalling it and reinstalling even different, obsolete versions - nothing worked.

The only thing I remember back from those few weeks when it worked - I've right clicked the tray icon and turned off something, but I think that uninstalling would have fixed this already. Just for record, erasing anything with the shell extension gives me loading cursor, but nothing ever shows up and the file is left untouched.

Managed to re-install the newest version properly and it actually started. I've changed around the settings a bit and needed to turn off the program, but now it doesn't start again.
While it was working, the context menu extensions didn't work at all too.
Last edited:
What version of windows are you using?
Do you see any errors in the windows event log?
Windows 7 Professional 64bit with Sp1.
Now that you mentioned, the event log shows that whenever I run eraser there always seem to be two errors, one concerning eraser.exe and kernelbase.dll and another error concerning eraser and net. runtime.

I've uninstalled my NET. runtime 4.5 and reinstalled it, but those errors still persist sadly.
Last edited: