W 7 64 bit wont run eraser after install


New Member
everytime i install it ,it say program quit working and windows is looking for a solution.Any idaes as to why.It is a new copy of window and it was like the 6 or 7th theng to install on comp after all the updates...thanks
Joel I was having this problem and none of the options you outlined fixed it. I too have a clean install and was getting the same error message. After playing around I was able to determine the problem is because I have my display font sizes set to be 125% under Control Panel > Display. Setting back to 100% fixed it, this is a consistently reproducible bug.
Well, I just started Eraser running at 125% text size (i.e. 128dpi) and the program started perfectly fine... What OS are you using and which version of Eraser

I am running Windows 7 x64 and I did a clean install of Eraser 6. It crashes immediately every time I try start it. I tried what you suggested here. But it still won't start.
Try an Eraser 6.2 build found on our downloads page. That'll record the crash and let me have some data to work with.
I had exactly the same problem as DanielCarrey on a a new Win 7 x64 machine at virtually the same stage of build as his. I uninstalled version 6.0 and installed today's build (which is listed in the 6.2 section but describes itself as, and the program ran, and I was able to run tasks. There is however an issue with the Recycle bin, on which I shall start a separate thread.

Before installing v6.2, I did change the icon size from 125% to 100%, so cannot comment as to whether Daniel's reproducible problem can be replicated on my machine. However, changing from 100% to 125% and back did not appear to affect the v6.2 build.

Yes that's my experience so far... I guess since it's fixed in trunk I'll leave it as that and not go bug-hunt in v6.0... unless others are affected by this. The ticket was intended to be more for the fact that UI calculations assumed a particular screen resolution; I'd have expected the screen to look "weird" but definitely not to crash...
I have the same issue with Eraser6.2 r1689.

It used to work, but I was playing with the scheduler and it crashed when creating a schedule.

Since then, it crashes on launch. I have uninstalled it and reinstalled it, and the same problem. I wondered if something in the schedule was causing the problem, so I tried looking through the registry for the schedule entries but wasn't able to identify the location where they are stored to remove them.

In any case... I get a crash on start in Win7 64 bit, no dialog box shows up.
The schedule is in %LOCALAPPDATA%\Eraser 6\Task List.ersx

If you manage to reproduce the crashing do let me know. Once that's been deleted, you can also start Eraser and upload the crash reports to our server. I'll review when I got time to.
It's definitely a corrupt task list. Now, that's usually caused by upgrading Eraser... did you?
Yes and no. I was using the build from a few days ago, and the problem happened with that build. I did upgrade to the build mentioned above.... and the problem continued. I cannot know if the cause of the crash was the same though.
When I had this issue with the 'stable' version (which, unlike your case, was resolved by installing a nightly build), I found a diagnostic report which seemed to relate to the crash in [USER]\%APPDATA%\Local\Elevated Diagnostics (you will need to turn on viewing of hidden and system files to see this folder). If there is a report there, Joel might like to know what it contains. To me, it would indicate some sort of issue with the dotNET framework runtime (= the Microsoft libraries). It might be worth downloading and reinstalling these, but it would be helpful if Joel could suggest which version you need (there are several).

A slightly less drastic option is to do a full uninstall of Eraser, if you can deleting the install folders and doing a registry clean, before reinstalling the nightly build. You may have already done this, of course.

Unfortunately, you seem to have a system- or installation-specific problem. As I said, Eraser 6.2 is now running normally on my Windows 7 x64 machine.

How about the registry key HKCU\Software\Eraser\Eraser 6? Have you deleted that and see if it resolves it? We depend a lot of the .NET serialisation capabilities which happens to be EXTREMELY FICKLE about the types stored in serialised streams. I think I've done something that isn't as the developers of the framework foresaw to be a standard use-case.
Well, then, I'll need more information than is available currently to give anything more specific.