Windows 7 with 64 bit


New Member
I have laptops that run Windows 7 64 bit on them. I have tried installing the current build (, with and without Administrator rights and am unable to get it to run. Previously you had an install for 64 bit processors, what happened to it, is it no longer supported??? Please HELP.
The 32 and 64 bit installers are both embedded in the Eraser install program, and I have yet to come across a case of the wrong version being installed. When you say you can't get it to run, what exactly happens?

You might like to read the FAQ post Common Eraser Questions, which has fixes for most of the more common failures we have seen. If you don't find your problem described there, please come back with a more detailed description of what happens.

Eraser seems to install as it should, but when I go to run eraser I get the message "Eraser has stopped working. Windows is checking for a solution." No solution is ever found and as a result it stops working! :(
Please read the FAQ post "Common Eraser Questions", which will tell you how to find the Task List file. Delete that and re-start Eraser. That's the first, and commonest, fix. If that doesn't work, come back; there are other things to try.

Thank you much four your assistance. I took your advice, I and deleted both task lists, uninstalled the program, removed the one line from the registry and reinstalled. It is now working as it should. Thanks again for the assist. :D
You took what would have been my next step! I'm glad it's working.

hi David,
i went to the FAQ to find the REGISTRY item i need to delete to be able to fix my problem.

but when i clicked the links it said that the posts no longer exist.

Could you help me out?

Sorry I didn't reply sooner. Can you tell me which links are not working? There have been some server issues recently, and the main Eraser site is still not working properly.

Hi david,

It looks like the links titled "guidance to his thread" in THIS THREAD have stopped working, although I have not checked the others, which may also be down.

Thank you,

{PS. I figured out you need to delete the whole registry folder titled "Eraser 6"}
Thanks for the heads up. I have edited the post to remove the dead links; the remainder were working as of the time of writing this.

Actually, a brute force uninstallation may require more than just removing the Eraser program keys. I usually use the search function in the registry editor to find all references to Eraser, and then remove as many as seem only to reference Eraser.

Unfortunately I'm experiencing the same problem reported earlier in this thread. After installing Eraser and running, I receive the error dialogue, "Eraser has stopped working Check online for a solution and close the program Close the program. I deleted the Task List file but wasn't able to find HKCU\Software\Eraser in the Registry. I did a search for that string but there were no returns. I'm running Windows 7 Home Premium, 64-bit version. I've uninstalled, rebooted, and re-installed Eraserseveral times but keep getting the same results.

Any assistance is more than appreciated!!

Please uninstall Eraser, remove the Eraser program folders and the Eraser 6 folder in your %LOCALAPPDATA% folder, then, as previously advised, use the Registry Editor to find and remove all keys and values that relate solely to Eraser before trying another install. So far, in otherwise intractable cases, that does it for me.

The attachment below is everything I found related to Eraser in the Registry on my machine. Having never made a change to the registry before, I wanted to check that the attached is okay to delete without causing any related problems.

Thanks again for the assistance!



  • Eraser.jpg
    13.7 KB · Views: 4,747
Thanks for the advice Greg. I made a back-up of the Registry, deleted the entries in my previous post, re-booted the system, installed Eraser, and unfortunately still get the same results. I went back into the Registry and didn't find any entries for Eraser. I also checked in the app data folder and didn't find a folder for Eraser and don't know what that might indicate.

The attachment below are the details from the error message. I certainly am not ruling out operator error, just don't know what else to do or where to look.

Any suggestions?


  • Eraser_Error_Message_W.jpg
    21.7 KB · Views: 3,223
If the install appeared to complete normally, I am afraid that you need to try again. Obviously, start by uninstalling Eraser, then deleting the program folder and the Eraser 6 folder in %LOCALAPPDATA%, if they exist. Your error would be consistent with allowing the folder in %LOCALAPPDATA% to remain, but there are other possible causes and you might as well do the whole job.

Once the folders are deleted, start the Registry Editor. Certainly delete the whole of that 'Eraser 6' tree you found, but you also need to sun a search in the Registry Editor (Ctrl+F from the top, then F3 to search again), to find every reference to Eraser in the Registry. Some of them are in pretty odd places. If a key only refers to Eraser, delete it. If it seems to refer to other programs also, delete just the values that refer to Eraser. I have never had a problem doing this, but a registry backup or a recent restore point would be good to have if needed.

Thanks for the advice David. I will follow the procedure although it may take me a while as I have a busy week coming up!

I'm having the same problem with the same symptoms. None of the registry entries or %APP...% locations exist. I am running Win7 Ultimate 64 Bit and Eraser is being installed into C:\Program Files\Eraser.
Eraser installed in standard mode and as Administrator. Same problem. No issues shown during install, but crashes on start.
I've found before that a failed installation can block all subsequent attempts to install. I have to repeat the advice to carry out a full, 'brute force' uninstall that I gave earlier. You need to find as many Eraser related registry keys or values as you can, and delete them all. The Windows installer itself seems to create a fair number of them.

Still no joy. Here's what I tried so far after the initial installation failed to run properly.

1. Removed Eraser the 'normal' way using Control Panel > Programs and Features > Uninstal Eraser.

2. Had a look around for any lingering program folders:
'c:\Program Files' does not include any Eraser folders or files.
'c:\Program Files (x86)' does not include any Eraser folders or files.

3. Looked for LocalAppData residue:
%LOCALAPPDATA% points to' C:\Users\ajl1\AppData\Local' in which there are no Eraser folders or files.

4. Checked the Registry:
HKCU\Software\Eraser does not exist.
Searched for and deleted any other Eraser entries in the Registry. Found entries:
HKEY_USERS\S-1-5-21-3551344946-471158596-2784738806-1000\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Persisted

5. Rebooted.

6. Reinstalled Eraser - > still not working correctly (same error as a previous screenshot).

7. Removed it all.

8. Tried both the 32 bit and 64 bit installers (found them in the %TEMP% folder mid way through a standard install). Problem still exists.

9. Tried installing Eraser to a different drive - > Problem still exists.

The only 'special' thing about this PC is that it has Windows installed on a SSD.

For info, after performing an install:

(a) A folder 'Eraser' is created in 'C:\Program Files' but not in #C:\Program Files (x86)' (indicating 64 bit installation).
(b) %LOCALAPPDATA% does not contain any Eraser folders.
(c) The registry contains several Eraser entries such as context handlers etc, suggesting the Registry is being correctly updated by the installer.